aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-09 19:21:54 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-09 23:02:39 -0800
commit0e902f8eb1096daaa85b6d11872dbcd0a62e518a (patch)
tree1f7aebbe6faf9201477dc5ed792daa4da306eabe /meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
parent299e3ac8859e8f0869c1f614a439aaead6167415 (diff)
downloadmeta-openembedded-contrib-0e902f8eb1096daaa85b6d11872dbcd0a62e518a.tar.gz
python3-asn1crypto: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
index cfbe57520c..1b03c666a4 100644
--- a/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
@@ -1,6 +1,24 @@
-inherit setuptools3
-require python-asn1crypto.inc
+DESCRIPTION = "A fast, pure Python library for parsing and serializing ASN.1 structures"
+HOMEPAGE = "https://github.com/wbond/asn1crypto"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7439e38f5e04ff62fae436184786b7ca"
+
+PYPI_PACKAGE = "asn1crypto"
+
+SRC_URI[md5sum] = "daad112940181917e3ff169b47b9bd9a"
+SRC_URI[sha256sum] = "5a215cb8dc12f892244e3a113fe05397ee23c5c4ca7a69cd6e69811755efc42d"
+
+inherit pypi setuptools3
RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netclient \
${PYTHON_PN}-shell \
"
+
+BBCLASSEXTEND = "native nativesdk"