aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-arpeggio_1.9.2.bb
diff options
context:
space:
mode:
authorVyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>2020-04-08 14:35:51 +0200
committerKhem Raj <raj.khem@gmail.com>2020-04-08 11:21:13 -0700
commit26801c58ee2b0621bd55fc6269abc874d5da5017 (patch)
treecdffedc79971943ff142e4ec67542cdc142d828f /meta-python/recipes-devtools/python/python3-arpeggio_1.9.2.bb
parent0e34b28d2e81a399aa7b6ef685fde20b3670bd6e (diff)
downloadmeta-openembedded-contrib-26801c58ee2b0621bd55fc6269abc874d5da5017.tar.gz
python3-arpeggio: add new recipe
Arpeggio is a recursive descent parser with memoization based on PEG grammars (aka Packrat parser) Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-arpeggio_1.9.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-arpeggio_1.9.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-arpeggio_1.9.2.bb b/meta-python/recipes-devtools/python/python3-arpeggio_1.9.2.bb
new file mode 100644
index 0000000000..802a5b2eaa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-arpeggio_1.9.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Arpeggio is a recursive descent parser with memoization based on PEG grammars (aka Packrat parser)"
+HOMEPAGE = "https://pypi.org/project/Arpeggio/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=33b8d1ba459a2fa4d801acfd1d1b7ceb"
+
+SRC_URI[md5sum] = "39667a626217c670bc634444be6e904a"
+SRC_URI[sha256sum] = "948ce06163a48a72c97f4fe79ad3d1c1330b6fec4f22ece182fb60ef60bd022b"
+
+PYPI_PACKAGE = "Arpeggio"
+inherit pypi setuptools3
+
+# setup.py of Arpeggio needs this.
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+BBCLASSEXTEND = "native nativesdk"