aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-argcomplete_1.12.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-22 12:44:10 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-26 08:22:59 -0700
commit5d187e95b8dc7edb02d8e12bcb7da12cb82cdc20 (patch)
tree56f0578196711363818ca64d50ee78e91f683da1 /meta-python/recipes-devtools/python/python3-argcomplete_1.12.3.bb
parent440f11c497ca779bf70b3a040eb0c37ca82b97b7 (diff)
downloadmeta-openembedded-contrib-5d187e95b8dc7edb02d8e12bcb7da12cb82cdc20.tar.gz
python3-argcomplete: Upgrade 1.12.2 -> 1.12.3
Upgrade to release 1.12.3: - Help string support for fish - Add option to use tempfiles for IPC - Fix multiple command registration for non-bash shells - Register auto completion for an arbitrary name using a given external script - Skip completions from active subprocess completer - Fix warnings regarding invalid escape sequences Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-argcomplete_1.12.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-argcomplete_1.12.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-argcomplete_1.12.3.bb b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.3.bb
new file mode 100644
index 0000000000..7fdf9e0190
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.3.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Argcomplete provides easy, extensible command line tab completion of arguments for your Python script."
+HOMEPAGE = "https://github.com/kislyuk/argcomplete"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[sha256sum] = "2c7dbffd8c045ea534921e63b0be6fe65e88599990d8dc408ac8c542b72a5445"
+
+PYPI_PACKAGE = "argcomplete"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+