aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-argcomplete_1.12.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-28 11:00:57 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-30 15:57:51 -0700
commitc04c92ec5c03e3e6fde3cb43262c7071664d23ce (patch)
tree917e35b2d243ef79cb885b1edaf09299c1cdb08a /meta-python/recipes-devtools/python/python3-argcomplete_1.12.1.bb
parentc65f93c44f60b8b79d2c4fde131302a615dff52f (diff)
downloadmeta-openembedded-contrib-c04c92ec5c03e3e6fde3cb43262c7071664d23ce.tar.gz
python3-argcomplete: Upgrade 1.12.0 -> 1.12.1
Upgrade to release 1.12.1: - Update importlib-metadata dependency version range - Bash nounset mode fixes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-argcomplete_1.12.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-argcomplete_1.12.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-argcomplete_1.12.1.bb b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.1.bb
new file mode 100644
index 0000000000..c14a7eba12
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Argcomplete provides easy, extensible command line tab completion of arguments for your Python script."
+HOMEPAGE = "https://github.com/kislyuk/argcomplete"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[md5sum] = "2262d0466a40d42267b424bba5010a0b"
+SRC_URI[sha256sum] = "849c2444c35bb2175aea74100ca5f644c29bf716429399c0f2203bb5d9a8e4e6"
+
+PYPI_PACKAGE = "argcomplete"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+