aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-05-20 17:15:02 +0300
committerKhem Raj <raj.khem@gmail.com>2020-05-21 15:09:34 -0700
commit9108c29005f416315d9cfe9f61bd17e0b1163806 (patch)
treef6c4ecbfbc27a27191e25c61690aea37e265b009 /meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
parentbb4cdd4d80fe690a28c2c20048d675d4584ae9c7 (diff)
downloadmeta-openembedded-contrib-9108c29005f416315d9cfe9f61bd17e0b1163806.tar.gz
python3-appdirs: Upgrade to 1.4.4
Upgrade to release 1.4.4. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb b/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
new file mode 100644
index 0000000000..eef5c02735
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bb
@@ -0,0 +1,21 @@
+SUMMARY = "A small Python module for determining appropriate + platform-specific dirs, e.g. a user data dir."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=31625363c45eb0c67c630a2f73e438e4"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+SRC_URI[md5sum] = "d6bca12613174185dd9abc8a29f4f012"
+SRC_URI[sha256sum] = "7d5d0167b2b1ba821647616af46a749d1c653740dd0d2415100fe26e27afdf41"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
+}