aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiohttp_3.7.4.post0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-02 15:34:55 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-06 08:58:42 -0700
commit6cfe535f40e4e987b5b755ee59918643178a79b2 (patch)
tree59c2f98ac5d227f562f8308e872dbcc73a206da2 /meta-python/recipes-devtools/python/python3-aiohttp_3.7.4.post0.bb
parent0fc9235bbb8f4df0ac7b33f0b875e1fc36e1e563 (diff)
downloadmeta-openembedded-contrib-6cfe535f40e4e987b5b755ee59918643178a79b2.tar.gz
python3-aiohttp: Upgrade 3.7.4 -> 3.7.4.post0
Upgrade to release 3.7.4.post0: - Bumped upper bound of the chardet runtime dependency to allow their v4.0 version stream. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiohttp_3.7.4.post0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.7.4.post0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.7.4.post0.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.4.post0.bb
new file mode 100644
index 0000000000..8bf129d30c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.4.post0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Async http client/server framework"
+DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
+HOMEPAGE = "https://github.com/aio-libs/aiohttp"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3bf3d48554bdca1ea7fdb48de378c2ca"
+
+SRC_URI[sha256sum] = "493d3299ebe5f5a7c66b9819eacdcfbbaaf1a8e84911ddffcdc48888497afecf"
+
+PYPI_PACKAGE = "aiohttp"
+inherit setuptools3 pypi
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-async-timeout \
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-idna-ssl \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-typing-extensions \
+ ${PYTHON_PN}-yarl \
+"