aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.4.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-29 15:10:29 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-01 10:44:51 -0800
commit59506ec90ea39230ff29e2c4e1f1be6419ff8796 (patch)
treeb2bb609737c769a08bf72b54833778573527ccc9 /meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.4.2.bb
parentdc8afb18c1cea424e175473ab6ad550bd3809f40 (diff)
downloadmeta-openembedded-contrib-59506ec90ea39230ff29e2c4e1f1be6419ff8796.tar.gz
python3-aiohttp-jinja2: Upgrade 1.2.0 -> 1.4.2
Upgrade to release 1.4.2: - Fix type annotation for context_processors argument - Bump the minimal supported aiohttp version to 3.6.3 to avoid problems with uncompatibility between aiohttp and yarl - Add async rendering support - Document async rendering functions - Add CHANGES.rst to MANIFEST.in and sdist License-Update: Remove an empty line at the end of the file Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.4.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.4.2.bb b/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.4.2.bb
new file mode 100644
index 0000000000..05afed8b6e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiohttp-jinja2_1.4.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "jinja2 template renderer for aiohttp.web (http server for asyncio)"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=29dca541e03964615590ca7b50392d97"
+
+SRC_URI[sha256sum] = "9c22a0e48e3b277fc145c67dd8c3b8f609dab36bce9eb337f70dfe716663c9a0"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-jinja2 \
+ ${PYTHON_PN}-aiohttp \
+"
+
+BBCLASSEXTEND = "native nativesdk"