aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aenum_2.2.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-24 13:35:11 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-28 12:23:15 -0700
commitd02382a373732a3e29ec254fe536419a466fe399 (patch)
tree76d8c3a6d8493fcbd0bc9e2a6f8d1010b97cdd94 /meta-python/recipes-devtools/python/python3-aenum_2.2.4.bb
parent17f906e5ed8e1e89c74feb808a428ca7bb5071bd (diff)
downloadmeta-openembedded-contrib-d02382a373732a3e29ec254fe536419a466fe399.tar.gz
python3-aenum: Upgrade 2.2.3 -> 2.2.4
Upgrade to release 2.2.4: - add support to Constant to retrieve members by value - add pickle/deepcopy support to Constant - add support for Constant to use other Constant values - AutoNumber and auto() now work together - Enum members are now added to the class as enum_property, which supports unshadowing of parent class attributes when called on an Enum member Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aenum_2.2.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aenum_2.2.4.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aenum_2.2.4.bb b/meta-python/recipes-devtools/python/python3-aenum_2.2.4.bb
new file mode 100644
index 0000000000..da77a5c75e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aenum_2.2.4.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Advanced Enumerations library"
+HOMEPAGE = "https://pypi.org/project/aenum/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://aenum/LICENSE;md5=c6a85477543f8b8591b9c1f82abebbe9"
+
+SRC_URI[md5sum] = "8983562361efe5be865617341dadbb9b"
+SRC_URI[sha256sum] = "81828d1fbe20b6b188d75b21a0fa936d7d929d839ef843ef385d9c2a97082864"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"