aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyzmq
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-22 12:11:24 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-25 14:34:06 -0800
commitcc1290421086cb74f436e71158e31ccf3205acd0 (patch)
tree807dc1860a39f24d810051067763e31e6a7635a5 /meta-python/recipes-devtools/python/python-pyzmq
parent74269b3f8e9a02dcb01acdc8d12a59242a3422da (diff)
downloadmeta-openembedded-contrib-cc1290421086cb74f436e71158e31ccf3205acd0.tar.gz
python3-pyzmq: Upgrade 20.0.0 -> 21.0.1
Upgrade to release 21.0.1: - drop support for Python 3.5. Python >= 3.6 is required - mypy type stubs, which should improve static analysis of pyzmq, especially for dynamically defined attributes such as zmq constants. These are new! Let us know if you find any issues. - support for zero-copy and sending bufferables with cffi backend. This is experimental! Please report issues. - zero-copy support in CFFI backend (send(copy=False) now does something). - Support sending any buffer-interface-providing objects in CFFI backend. - Errors during teardown of asyncio Sockets - Missing MSVCP140.dll in Python 3.9 wheels on Windows, causing vcruntime-redist package to be required to use the Python 3.9 wheels for pyzmq 20.0 - pyzmq-21.0.1 only changes CI configuration for Windows wheels (built with VS2017 instead of VS2019), fixing compatibility with some older Windows on all Pythons and removing requirement of VC++ redistributable package on latest Windows and Python < 3.8. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyzmq')
-rw-r--r--meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch24
1 files changed, 21 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
index 936f165850..d4e144a610 100644
--- a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
+++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
@@ -1,13 +1,31 @@
+From b394003d31a7187767b7d6cc7b871968d2674be9 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Fri, 22 Jan 2021 11:41:12 +0200
+Subject: [PATCH] setup.py: Adjust _add_rpath
+
+Fix error: unrecognized command-line option '-R'
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+---
+ setup.py | 3 ---
+ 1 file changed, 3 deletions(-)
+
diff --git a/setup.py b/setup.py
-index d243eaa..98099bc 100755
+index 22f582d..2d28655 100755
--- a/setup.py
+++ b/setup.py
-@@ -192,8 +192,6 @@ def _add_rpath(settings, path):
+@@ -231,9 +231,6 @@ def _add_rpath(settings, path):
"""
if sys.platform == 'darwin':
- settings['extra_link_args'].extend(['-Wl,-rpath','-Wl,%s' % path])
+ settings['extra_link_args'].extend(['-Wl,-rpath', '-Wl,%s' % path])
- else:
- settings['runtime_library_dirs'].append(path)
+-
def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False):
"""load appropriate library/include settings from ZMQ prefix"""
+--
+2.17.1
+