aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyzmq
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2018-07-19 09:25:01 +0200
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:07:12 -0700
commit625e1e58d006938396c826dc9de56b0d0ca308a9 (patch)
tree5b7797f799b3a8596f00f8741fc4429530e80afd /meta-python/recipes-devtools/python/python-pyzmq
parentb0caf1fb82b90a6b123ba4463a8405568eda0389 (diff)
downloadmeta-openembedded-contrib-625e1e58d006938396c826dc9de56b0d0ca308a9.tar.gz
python-pyzmq, python3-pyzmq: update to 17.1.0
Also the package is licensed under both BSD and LGPL-3.0. This the license checksum was updated to reflect this. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyzmq')
-rw-r--r--meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch31
1 files changed, 9 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
index 2dc3b73f9e..936f165850 100644
--- a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
+++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
@@ -1,26 +1,13 @@
diff --git a/setup.py b/setup.py
-index 62df445..1fdbdeb 100755
+index d243eaa..98099bc 100755
--- a/setup.py
+++ b/setup.py
-@@ -213,12 +213,6 @@ def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False):
- pass
- # unused rpath args for OS X:
- # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/..']
-- else:
-- settings['runtime_library_dirs'] += ['$ORIGIN/..']
-- elif sys.platform != 'darwin':
-- settings['runtime_library_dirs'] += [
-- os.path.abspath(x) for x in settings['library_dirs']
-- ]
-
- return settings
+@@ -192,8 +192,6 @@ def _add_rpath(settings, path):
+ """
+ if sys.platform == 'darwin':
+ settings['extra_link_args'].extend(['-Wl,-rpath','-Wl,%s' % path])
+- else:
+- settings['runtime_library_dirs'].append(path)
-@@ -592,8 +586,6 @@ class Configure(build_ext):
- pass
- # unused rpath args for OS X:
- # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/../zmq']
-- else:
-- settings['runtime_library_dirs'] = [ os.path.abspath(pjoin('.', 'zmq')) ]
-
- line()
- info("Configure: Autodetecting ZMQ settings...")
+ def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False):
+ """load appropriate library/include settings from ZMQ prefix"""