aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-02-28 17:14:44 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-04 12:38:54 +0100
commit8f7e76fc14f7488a22eaaea3d3c012b778e4b2c1 (patch)
tree395edc4bd2d4d5c0aaf0debfc9bd27cdfcdbb063 /meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb
parent8eaaf546bfb6c2c0fd73c2630c66ecdb1a51aff3 (diff)
downloadmeta-openembedded-contrib-8f7e76fc14f7488a22eaaea3d3c012b778e4b2c1.tar.gz
python-pytest-runner: update to version 2.11.1
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb b/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb
new file mode 100644
index 0000000000..188ef2b3cc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e38b971c2b4c33b978d1b9c9ece9ae63"
+
+SRC_URI[md5sum] = "bdb73eb18eca2727944a2dcf963c5a81"
+SRC_URI[sha256sum] = "983a31eab45e375240e250161a556163bc8d250edaba97960909338c273a89b3"
+
+DEPENDS += " \
+ python-setuptools-scm"
+
+RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json \
+ python-compiler python-io"
+
+inherit pypi setuptools