aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pysnmp_4.4.9.bb
diff options
context:
space:
mode:
authorthstead <thstead@steadtechnology.co.uk>2019-05-21 20:20:25 +0100
committerKhem Raj <raj.khem@gmail.com>2019-05-21 17:52:23 -0700
commit5e00cd863a81939bf1ead765632b5a57e1dd331c (patch)
tree34bf1ec85c34f6baf115801d90eac6dfd0cf00b6 /meta-python/recipes-devtools/python/python-pysnmp_4.4.9.bb
parent05138d26fe91f3a8c72857714daae689a6ff0aa5 (diff)
downloadmeta-openembedded-contrib-5e00cd863a81939bf1ead765632b5a57e1dd331c.tar.gz
Upgraded python-pysnmp from version 4.3.5. to 4.4.9.
This upgrade corrects a parameter issue on the Integer32.clone method within __SNMP-FRAMEWORK-MIB.py LICENSE checksum has also been updated to reflect the change of filename from LICENSE.txt to LICENSE.rst Signed-off-by: thstead <thstead@steadtechnology.co.uk> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pysnmp_4.4.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pysnmp_4.4.9.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pysnmp_4.4.9.bb b/meta-python/recipes-devtools/python/python-pysnmp_4.4.9.bb
new file mode 100644
index 0000000000..9ff4df2c93
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pysnmp_4.4.9.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A pure-Python SNMPv1/v2c/v3 library"
+DESCRIPTION = "SNMP v1/v2c/v3 engine and apps written in pure-Python. \
+ Supports Manager/Agent/Proxy roles, scriptable MIBs, asynchronous \
+ operation (asyncio, twisted, asyncore) and multiple transports.\
+"
+HOMEPAGE = "https://pypi.python.org/pypi/pysnmp"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=b15d29f500f748d1c2a15709769090a8"
+
+SRCNAME = "pysnmp"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "6d1b514997326bed18f1ae1510f6b1c9"
+SRC_URI[sha256sum] = "d5d1e59780126e963dd92e25993b783295734e71bef181f602e51f7393260441"
+
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-pycrypto \
+ python-pyasn1 \
+ python-pysmi \
+"