aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pygpgme
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-05-24 09:52:35 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-24 07:23:54 -0700
commit07fad37c9818a9f365c1f82f6f1907cafdb1d1f6 (patch)
tree1870794108a077e2cf18f70ad2fc88680a1c7b0b /meta-python/recipes-devtools/python/python-pygpgme
parent26397c2ea3fe904cc99cd767c9e2b1c5b3840321 (diff)
downloadmeta-openembedded-contrib-07fad37c9818a9f365c1f82f6f1907cafdb1d1f6.tar.gz
meta-python: remove unused patches from python2 recipes
* python2 recipes were removed in: https://git.openembedded.org/meta-openembedded/commit/?id=05d0c5eee319055816bbea8b9dd972f723f68019 but some of the unused patch files were left behind * meta-python/recipes-devtools/python/python-pyrex/pyrex-fix-optimized-mode.patch: https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch meta-python/recipes-devtools/python/python-imaging/fix-freetype-includes.patch meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-numeric_24.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pygpgme')
-rw-r--r--meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch90
-rw-r--r--meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch52
-rw-r--r--meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch30
-rw-r--r--meta-python/recipes-devtools/python/python-pygpgme/run-ptest3
4 files changed, 0 insertions, 175 deletions
diff --git a/meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch b/meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch
deleted file mode 100644
index 1f31cb805e..0000000000
--- a/meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From ed44474c11f577c1644910964a917a4cf701bb0f Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Tue, 26 Jan 2016 14:24:26 -0500
-Subject: [PATCH] reflect 2.1 reporting for key imports
-
-GnuPG 2.1 changes how it reports key imports. These changes should
-make the pygpgme test suite compatible with GnuPG 2.1.
-
-See also:
-https://lists.gnupg.org/pipermail/gnupg-devel/2016-January/030718.html
-
-Upstream-Status: Backport
-
-Signed-off-by: Catalin Enache <catalin.enache@windriver.com>
-
----
- tests/test_import.py | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/tests/test_import.py b/tests/test_import.py
-index 10eb816..597eb47 100644
---- a/tests/test_import.py
-+++ b/tests/test_import.py
-@@ -55,7 +55,7 @@ class ImportTestCase(GpgHomeTestCase):
- ctx = gpgme.Context()
- with self.keyfile('key1.sec') as fp:
- result = ctx.import_(fp)
-- self.assertEqual(result.considered, 1)
-+ self.assertEqual(result.considered, 3)
- self.assertEqual(result.no_user_id, 0)
- self.assertEqual(result.imported, 1)
- self.assertEqual(result.imported_rsa, 0)
-@@ -64,18 +64,18 @@ class ImportTestCase(GpgHomeTestCase):
- self.assertEqual(result.new_sub_keys, 0)
- self.assertEqual(result.new_signatures, 0)
- self.assertEqual(result.new_revocations, 0)
-- self.assertEqual(result.secret_read, 1)
-- self.assertEqual(result.secret_imported, 1)
-+ self.assertEqual(result.secret_read, 3)
-+ self.assertEqual(result.secret_imported, 2)
- self.assertEqual(result.secret_unchanged, 0)
- self.assertEqual(result.skipped_new_keys, 0)
- self.assertEqual(result.not_imported, 0)
- self.assertEqual(len(result.imports), 2)
- self.assertEqual(result.imports[0],
- ('E79A842DA34A1CA383F64A1546BB55F0885C65A4',
-- None, gpgme.IMPORT_NEW | gpgme.IMPORT_SECRET))
-+ None, gpgme.IMPORT_NEW))
- self.assertEqual(result.imports[1],
- ('E79A842DA34A1CA383F64A1546BB55F0885C65A4',
-- None, gpgme.IMPORT_NEW))
-+ None, gpgme.IMPORT_NEW | gpgme.IMPORT_SECRET))
- # can we get the public key?
- key = ctx.get_key('E79A842DA34A1CA383F64A1546BB55F0885C65A4')
- # can we get the secret key?
-@@ -102,17 +102,17 @@ class ImportTestCase(GpgHomeTestCase):
- fp = BytesIO(b'\n'.join(keys))
- ctx = gpgme.Context()
- result = ctx.import_(fp)
-- self.assertEqual(result.considered, 3)
-+ self.assertEqual(result.considered, 5)
- self.assertEqual(result.no_user_id, 0)
- self.assertEqual(result.imported, 2)
-- self.assertEqual(result.imported_rsa, 1)
-+ self.assertEqual(result.imported_rsa, 0)
- self.assertEqual(result.unchanged, 0)
- self.assertEqual(result.new_user_ids, 0)
- self.assertEqual(result.new_sub_keys, 0)
- self.assertEqual(result.new_signatures, 1)
- self.assertEqual(result.new_revocations, 0)
-- self.assertEqual(result.secret_read, 1)
-- self.assertEqual(result.secret_imported, 1)
-+ self.assertEqual(result.secret_read, 3)
-+ self.assertEqual(result.secret_imported, 2)
- self.assertEqual(result.secret_unchanged, 0)
- self.assertEqual(result.skipped_new_keys, 0)
- self.assertEqual(result.not_imported, 0)
-@@ -122,10 +122,10 @@ class ImportTestCase(GpgHomeTestCase):
- None, gpgme.IMPORT_NEW))
- self.assertEqual(result.imports[1],
- ('E79A842DA34A1CA383F64A1546BB55F0885C65A4',
-- None, gpgme.IMPORT_NEW | gpgme.IMPORT_SECRET))
-+ None, gpgme.IMPORT_SIG))
- self.assertEqual(result.imports[2],
- ('E79A842DA34A1CA383F64A1546BB55F0885C65A4',
-- None, gpgme.IMPORT_SIG))
-+ None, gpgme.IMPORT_NEW | gpgme.IMPORT_SECRET))
- self.assertEqual(result.imports[3],
- ('93C2240D6B8AA10AB28F701D2CF46B7FC97E6B0F',
- None, gpgme.IMPORT_NEW))
diff --git a/meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch b/meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch
deleted file mode 100644
index c18cf3feba..0000000000
--- a/meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From ba0dc8273e4f83bcd2d43baa5910aae34b93048c Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Mon, 1 Feb 2016 19:25:12 -0500
-Subject: [PATCH] passphrase_cb is deprecated
-
-https://bugs.gnupg.org/gnupg/issue767 indicates that
-gpgme_set_passphrase_cb is a deprecated corner of the API and that
-developers using gpgme should really rely on the gpg-agent to handle
-this stuff. This should actually simplify things for most
-installations -- just strip out all passphrase handling from your
-application entirely, relying on gpg to figure out how to find the
-agent, and relying on the agent figuring out how to prompt the user
-(if necessary).
-
-However, if a developer really wants to use the passphrase callback
-approach, they'll have to use loopback pinentry. This sets up the
-test suite to be able to make those tests.
-
-Upstream-Status: Backport
-
-Signed-off-by: Catalin Enache <catalin.enache@windriver.com>
-
----
- tests/util.py | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/tests/util.py b/tests/util.py
-index cd803c2..86892ca 100644
---- a/tests/util.py
-+++ b/tests/util.py
-@@ -28,7 +28,9 @@ keydir = os.path.join(os.path.dirname(__file__), 'keys')
-
- class GpgHomeTestCase(unittest.TestCase):
-
-- gpg_conf_contents = ''
-+ gpg_conf_contents = 'pinentry-mode loopback'
-+ gpg_agent_conf_contents = 'allow-loopback-pinentry'
-+
- import_keys = []
-
- def keyfile(self, key):
-@@ -41,6 +43,10 @@ class GpgHomeTestCase(unittest.TestCase):
- fp.write(self.gpg_conf_contents.encode('UTF-8'))
- fp.close()
-
-+ fp = open(os.path.join(self._gpghome, 'gpg-agent.conf'), 'wb')
-+ fp.write(self.gpg_agent_conf_contents.encode('UTF-8'))
-+ fp.close()
-+
- # import requested keys into the keyring
- ctx = gpgme.Context()
- for key in self.import_keys:
diff --git a/meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch b/meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch
deleted file mode 100644
index 6acb68bfe7..0000000000
--- a/meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 579b5930e15de8855bf63b3c20b6c3aaf894c3eb Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Mon, 1 Feb 2016 19:27:59 -0500
-Subject: [PATCH] handle generic error when no passphrase callback present
-
-apparently gpg 2.1 returns ERR_GENERAL right now if the pinentry was
-in loopback mode and no passphrase callback was supplied. Earlier
-versions supplied ERR_BAD_PASSPHRASE.
-
-Upstream-Status: Backport
-
-Signed-off-by: Catalin Enache <catalin.enache@windriver.com>
-
----
- tests/test_passphrase.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test_passphrase.py b/tests/test_passphrase.py
-index 0a235e9..35b3c59 100644
---- a/tests/test_passphrase.py
-+++ b/tests/test_passphrase.py
-@@ -41,7 +41,7 @@ class PassphraseTestCase(GpgHomeTestCase):
- new_sigs = ctx.sign(plaintext, signature, gpgme.SIG_MODE_CLEAR)
- except gpgme.GpgmeError as exc:
- self.assertEqual(exc.args[0], gpgme.ERR_SOURCE_GPGME)
-- self.assertEqual(exc.args[1], gpgme.ERR_BAD_PASSPHRASE)
-+ self.assertEqual(exc.args[1], gpgme.ERR_GENERAL)
- else:
- self.fail('gpgme.GpgmeError not raised')
-
diff --git a/meta-python/recipes-devtools/python/python-pygpgme/run-ptest b/meta-python/recipes-devtools/python/python-pygpgme/run-ptest
deleted file mode 100644
index ce2abb66a5..0000000000
--- a/meta-python/recipes-devtools/python/python-pygpgme/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-GPG_AGENT_INFO= python test_all.py -v 2>&1 | sed -e '/\.\.\. ok/ s/^/PASS: /g' -e '/\.\.\. [ERROR|FAIL]/ s/^/FAIL: /g' -e '/\.\.\. skipped/ s/^/SKIP: /g' -e 's/ \.\.\. ok//g' -e 's/ \.\.\. ERROR//g' -e 's/ \.\.\. FAIL//g' -e 's/ \.\.\. skipped//g'