aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pip_10.0.1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-06-26 14:00:49 +0800
committerKhem Raj <raj.khem@gmail.com>2018-06-27 22:17:33 -0700
commit064e5ab4630cc816675a15e119e9300c14aefc52 (patch)
tree61ea068f5a3be0f2f1ba8f783afdabd43beadc7a /meta-python/recipes-devtools/python/python-pip_10.0.1.bb
parentc8cec047811dfdaae82d9e7b892ef4f041f65a92 (diff)
downloadmeta-openembedded-contrib-064e5ab4630cc816675a15e119e9300c14aefc52.tar.gz
python-pip: upgrade 9.0.3 -> 10.0.1
The license checksum changes but the license remains the same. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pip_10.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pip_10.0.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pip_10.0.1.bb b/meta-python/recipes-devtools/python/python-pip_10.0.1.bb
new file mode 100644
index 0000000000..5aaf818d0d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pip_10.0.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages"
+HOMEPAGE = "https://pip.pypa.io/"
+LICENSE = "MIT & LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f8d33acaac5c5dac8c613904bd56a6f"
+
+SRC_URI[md5sum] = "83a177756e2c801d0b3a6f7b0d4f3f7e"
+SRC_URI[sha256sum] = "f2bd08e0cd1b06e10218feaf6fef299f473ba706582eb3bd9d52203fdbd7ee68"
+
+inherit pypi setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN}_class-target = "python-modules python-distribute python-misc"
+
+BBCLASSEXTEND = "native nativesdk"