aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-01 15:27:20 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-05 14:34:23 +0200
commit23cd1a50d0b571c96b4aaa8e1ed5a19af82a4085 (patch)
tree42afa07f6e3947fd8e111c3d203ace2850be26d5 /meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb
parent6bd0135ef64fb2385e8690d4066d1926200c5b38 (diff)
downloadmeta-openembedded-contrib-23cd1a50d0b571c96b4aaa8e1ed5a19af82a4085.tar.gz
python-matplotlib: Upgrade to 2.0.2
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb b/meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb
new file mode 100644
index 0000000000..5b1c3f05b9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74"
+
+DEPENDS += "python-numpy freetype libpng python-dateutil python-pytz"
+RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng python-dateutil python-pytz"
+
+SRC_URI = "https://github.com/matplotlib/matplotlib/archive/v${PV}.tar.gz \
+ file://fix_setupext.patch \
+"
+SRC_URI[md5sum] = "89717c1ef3c6fdcd6fb1f3b597a4858c"
+SRC_URI[sha256sum] = "aebed23921562792b68b8ca355de5abc176af4424f1987e2fa95f65e5c5e7e89"
+S = "${WORKDIR}/matplotlib-${PV}"
+EXTRA_OECONF = "--disable-docs"
+
+inherit setuptools pkgconfig
+