aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 13:34:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 12:49:45 +0200
commitd22f4ca2e3e421615b601002061690a8f97257c0 (patch)
tree8cfee5bd859365868dc3cb5eb9ba91d9713efb79 /meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
parent2d7c7956bd3655755e1e800b7b05732f0c1a3786 (diff)
downloadmeta-openembedded-contrib-d22f4ca2e3e421615b601002061690a8f97257c0.tar.gz
meta-python: rename recipes-python to recipes-devtools
* match old structure from meta-oe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch b/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
new file mode 100644
index 0000000000..9381583537
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
@@ -0,0 +1,29 @@
+This fixes the dependency checks inside of setup.py since things like
+'import numpy' won't work with bitbake.
+
+diff --git a/setup.py b/setup.py
+index 2f13821..e6d6ed0 100644
+--- a/setup.py
++++ b/setup.py
+@@ -113,12 +113,6 @@ if 1:
+ baseline_images = [chop_package(f) for f in baseline_images]
+ package_data['matplotlib'].extend(baseline_images)
+
+-if not check_for_numpy():
+- sys.exit(1)
+-
+-if not check_for_freetype():
+- sys.exit(1)
+-
+ build_ft2font(ext_modules, packages)
+ build_ttconv(ext_modules, packages)
+ build_contour(ext_modules, packages)
+@@ -129,7 +123,7 @@ build_tri(ext_modules, packages)
+
+ print_raw("")
+ print_raw("OPTIONAL BACKEND DEPENDENCIES")
+-has_libpng = check_for_libpng()
++has_libpng = True
+
+ if has_libpng and options['build_agg']:
+ build_agg(ext_modules, packages)