aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:35 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commit15bd5f4ebb70f3cfc36534a759ce2dbd6515d6e6 (patch)
tree267f9b3093ce0d3d7b6b8af4aa13338f7418627d /meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
parentb3b34496758768d06a18621754492dde730c9423 (diff)
downloadmeta-openembedded-contrib-15bd5f4ebb70f3cfc36534a759ce2dbd6515d6e6.tar.gz
python{, 3}-m2crypto: update from 0.26.4 -> 0.30.1
Updating recipe for crypto and SSL toolkit for python and support python3 infrastructure of Yocto as well as the already supported python2 line. Refresh patches to fix devtool warnings Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch21
1 files changed, 12 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch b/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
index c6654e5402..4b64f4613c 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
@@ -4,27 +4,30 @@ since it pokes at the system for getting architecture values
Upstream-Status: Inappropriate
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Index: M2Crypto-0.26.0/setup.py
+Index: M2Crypto-0.30.1/setup.py
===================================================================
---- M2Crypto-0.26.0.orig/setup.py
-+++ M2Crypto-0.26.0/setup.py
-@@ -141,19 +141,6 @@ class _M2CryptoBuildExt(build_ext.build_
- self.include_dirs.append(
- os.path.join(self.openssl, 'include', 'openssl'))
+--- M2Crypto-0.30.1.orig/setup.py
++++ M2Crypto-0.30.1/setup.py
+@@ -160,22 +160,6 @@ class _M2CryptoBuildExt(build_ext.build_
+ log.debug('self.include_dirs = %s', self.include_dirs)
+ log.debug('self.library_dirs = %s', self.library_dirs)
+- if platform.system() == "Linux":
- # For RedHat-based distros, the '-D__{arch}__' option for
- # Swig needs to be normalized, particularly on i386.
- mach = platform.machine().lower()
- if mach in ('i386', 'i486', 'i586', 'i686'):
- arch = '__i386__'
-- elif mach in ('ppc64', 'powerpc64'):
+- elif mach in ('ppc64', 'powerpc64', 'ppc64le', 'ppc64el'):
- arch = '__powerpc64__'
- elif mach in ('ppc', 'powerpc'):
- arch = '__powerpc__'
- else:
- arch = '__%s__' % mach
- self.swig_opts.append('-D%s' % arch)
+- if mach in ('ppc64le', 'ppc64el'):
+- self.swig_opts.append('-D_CALL_ELF=2')
-
self.swig_opts.extend(['-I%s' % i for i in self.include_dirs])
- self.swig_opts.append('-includeall')
- self.swig_opts.append('-modern')
+
+ # Some Linux distributor has added the following line in