aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-gevent
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-02 14:28:08 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-05 13:04:40 -0700
commitaac74bcb8135a44514821551b1126946f2a30434 (patch)
tree5ead1d8b42b1481e398d6a7f26bd0ed3b4f980f6 /meta-python/recipes-devtools/python/python-gevent
parenta425609f8bddc22c74216b4d613492c25b0970c7 (diff)
downloadmeta-openembedded-contrib-aac74bcb8135a44514821551b1126946f2a30434.tar.gz
python3-gevent: Upgrade 1.4.0 -> 20.6.2
Upgrade to release 20.6.2: - It is now possible to build and use the embedded libuv on a Cygwin platform. - Bug fix: relax the version constraint for psutil on PyPy. - The include directories used to compile the C extensions have been tweaked with the intent of making it easier to use older debug versions of Python. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-gevent')
-rw-r--r--meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch26
1 files changed, 0 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch b/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch
deleted file mode 100644
index 7536b71a69..0000000000
--- a/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From a53ed6b2f967a5f95e69d51cad3f8c120d7df65b Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Thu, 7 Feb 2019 15:21:15 +0100
-Subject: [PATCH] setup.py: do not query for include dir
-
-As this will return the native python directory erroneously.
-
-Upstream-Status: Inappropriate [oe-core specific]
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 86d6c5a..5d22291 100755
---- a/setup.py
-+++ b/setup.py
-@@ -52,7 +52,7 @@ from _setupares import ARES
- # Get access to the greenlet header file.
- # The sysconfig dir is not enough if we're in a virtualenv
- # See https://github.com/pypa/pip/issues/4610
--include_dirs = [sysconfig.get_path("include")]
-+include_dirs = []
- venv_include_dir = os.path.join(sys.prefix, 'include', 'site',
- 'python' + sysconfig.get_python_version())
- venv_include_dir = os.path.abspath(venv_include_dir)