aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-06-09 14:28:45 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-14 14:51:15 +0200
commitc7252e7c58c371c0db6645ce0bd1c794f127eb60 (patch)
tree688964dc23035765f4a7419789e87d8705ec4f33 /meta-python/recipes-devtools/python/python-django-south_1.0.2.bb
parent990b2ecf2c041d615ad0d07bd28a9ca77d0b2521 (diff)
downloadmeta-openembedded-contrib-c7252e7c58c371c0db6645ce0bd1c794f127eb60.tar.gz
python3-django-south: add new recipe
* move the common portions into .inc * add new recipe for python3-django-south Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-django-south_1.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-django-south_1.0.2.bb19
1 files changed, 2 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb b/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb
index 3a27758074..357b766a3d 100644
--- a/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb
+++ b/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb
@@ -1,17 +1,2 @@
-SUMMARY = "Migrations for Django"
-DESCRIPTION = "South is an intelligent database migrations library for the Django web framework. It is database-independent and DVCS-friendly, as well as a whole host of other features."
-HOMEPAGE = "http://south.aeracode.org/"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=17;endline=18;md5=2155d8ae21e7c23101d5febac696b27e"
-
-SRC_URI[md5sum] = "c76a9758b2011bc3b6c39f881bba2f66"
-SRC_URI[sha256sum] = "d360bd31898f9df59f6faa786551065bba45b35e7ee3c39b381b4fbfef7392f4"
-
-PYPI_PACKAGE = "South"
-inherit pypi setuptools
-
-BBCLASSEXTEND = "nativesdk"
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-django \
- "
+require python-django-south.inc
+inherit setuptools