aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-dbus_1.2.8.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-06-26 14:00:46 +0800
committerKhem Raj <raj.khem@gmail.com>2018-06-27 22:17:33 -0700
commitfc5d2e5e13763bc5155ef8a25e3a165ff08d5edd (patch)
treeded8cbcc0457f308d0cdf7906e818668239e3e4d /meta-python/recipes-devtools/python/python-dbus_1.2.8.bb
parent5fc8680e27fca3e5fb24cf38f769a421e72ac95f (diff)
downloadmeta-openembedded-contrib-fc5d2e5e13763bc5155ef8a25e3a165ff08d5edd.tar.gz
python-dbus: upgrade 1.2.6 -> 1.2.8
1. Remove obsolete PACKAGECONFIG. 2. Explicitly disable building documenation. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-dbus_1.2.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-dbus_1.2.8.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbus_1.2.8.bb b/meta-python/recipes-devtools/python/python-dbus_1.2.8.bb
new file mode 100644
index 0000000000..b3f7240547
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dbus_1.2.8.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Python bindings for the DBus inter-process communication system"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT & AFL-2.1 | GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
+ file://dbus-gmain/COPYING;md5=05c3eacd50f69bb1d58afec460baad57 "
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "7379db774c10904f27e7e2743d90fb43"
+SRC_URI[sha256sum] = "abf12bbb765e300bf8e2a1b2f32f85949eab06998dbda127952c31cb63957b6f"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+# documentation needs python-sphinx, which is not in oe-core or meta-python for now
+# change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python
+EXTRA_OECONF += "--disable-documentation"
+
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"
+
+do_install_append() {
+ # Remove files that clash with python3-dbus; their content is same
+ rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
+}