aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2017-07-09 17:47:22 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:32 +0200
commit5dcaa1231be0a2d6ded44855f8b5b054cb04c6f3 (patch)
tree649819e6f15ebe126926c22198bc273b7181a6b3 /meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
parent5623b70c79ace30556ca59052a80a04030c9e66f (diff)
downloadmeta-openembedded-contrib-5dcaa1231be0a2d6ded44855f8b5b054cb04c6f3.tar.gz
meta-python: Add python-daemon recipe and its dependencies
Add recipes for python-daemon PIP package with its dependencies - lockfile and docutils. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-daemon_2.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-daemon_2.1.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
new file mode 100644
index 0000000000..4c18e2bad5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Library to implement a well-behaved Unix daemon process"
+HOMEPAGE = "https://pagure.io/python-daemon/"
+SECTION = "devel/python"
+
+DEPENDS = "python-docutils"
+RDEPENDS_${PN} = "python-docutils \
+ python-lockfile (>= 0.10) \
+ python-resource \
+"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "9c57343d81f2a96c51cffeab982b04d2"
+SRC_URI[sha256sum] = "261c859be5c12ae7d4286dc6951e87e9e1a70a882a8b41fd926efc1ec4214f73"
+
+# Fix for build error in Yocto:
+# i = p.rfind('/') + 1
+# AttributeError: 'NoneType' object has no attribute 'rfind'
+#S = "${WORKDIR}/python-daemon"
+SRC_URI_append = " \
+ file://0001-Workaround-for-issue-2-1.patch \
+"
+
+PYPI_PACKAGE = "python-daemon"