aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-cryptography_2.2.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-06-29 16:45:44 -0400
committerKhem Raj <raj.khem@gmail.com>2018-06-29 15:53:09 -0700
commit3ee1d8b9ab0cd4ff8419a7daff997e356a2cd981 (patch)
tree41ed27f54f5773524c22730d76e2b971672a089f /meta-python/recipes-devtools/python/python-cryptography_2.2.2.bb
parentbc30a935763dc7e6304570758c363306841bc5a5 (diff)
downloadmeta-openembedded-contrib-3ee1d8b9ab0cd4ff8419a7daff997e356a2cd981.tar.gz
python-cryptography: update to version 2.2.2
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cryptography_2.2.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_2.2.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography_2.2.2.bb b/meta-python/recipes-devtools/python/python-cryptography_2.2.2.bb
new file mode 100644
index 0000000000..9c2f88418d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography_2.2.2.bb
@@ -0,0 +1,22 @@
+inherit pypi setuptools
+require python-cryptography.inc
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+DEPENDS += " \
+ ${PYTHON_PN}-enum34 \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+"
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-subprocess \
+"