aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-coloredlogs.inc
diff options
context:
space:
mode:
authorWindel Bouwman <windel.bouwman@gmail.com>2019-07-30 07:27:21 +0200
committerKhem Raj <raj.khem@gmail.com>2019-07-30 19:15:24 -0700
commitbc27c62dced424e9e9f49fa13041f575a0b41fad (patch)
tree0d83d0f1bbc6a729c1f96aba49c7c4574b59128a /meta-python/recipes-devtools/python/python-coloredlogs.inc
parentda6b51b555eeff3edad86fb29ee7d95b6f295372 (diff)
downloadmeta-openembedded-contrib-bc27c62dced424e9e9f49fa13041f575a0b41fad.tar.gz
Add recipe for the coloredlogs python package.
Signed-off-by: Windel Bouwman <windel.bouwman@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-coloredlogs.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-coloredlogs.inc24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-coloredlogs.inc b/meta-python/recipes-devtools/python/python-coloredlogs.inc
new file mode 100644
index 0000000000..f43bea1f74
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-coloredlogs.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "Colored terminal output for Python's logging module"
+HOMEPAGE = "https://coloredlogs.readthedocs.io"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=690da298a43805797a4fa7bbe180b3c6"
+
+SRC_URI[md5sum] = "0a186966a1955fff8cf9489373e691d9"
+SRC_URI[sha256sum] = "b869a2dda3fa88154b9dd850e27828d8755bfab5a838a1c97fbc850c6e377c36"
+
+inherit pypi
+
+do_compile_prepend() {
+ sed -ie "s/find_pth_directory(),/'',/g" setup.py
+}
+
+do_install_append() {
+ rm -rf ${D}${datadir}
+}
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-humanfriendly \
+"
+
+BBCLASSEXTEND = "native"