aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:18 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commit9d9a616a392deeb06bf7458902281c9bfeb7f5b6 (patch)
treedccc15079aa4f39de3266c838415202ada4a4060 /meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb
parentb62ae60f869b83721757a2f5316cdc26c1030af3 (diff)
downloadmeta-openembedded-contrib-9d9a616a392deeb06bf7458902281c9bfeb7f5b6.tar.gz
Update python recipes to use the common pypi package
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb11
1 files changed, 2 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb b/meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb
index 9caae41bf8..5e2d1741fd 100644
--- a/meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb
+++ b/meta-python/recipes-devtools/python/python-backports-ssl_3.4.0.2.bb
@@ -5,19 +5,12 @@ that you are trying to reach. But the matching logic, defined in RFC2818, can be
on your own. So the ssl package in the Standard Library of Python 3.2 and greater now includes a \
match_hostname() function for performing this check instead of requiring every application to \
implement the check separately. This backport brings match_hostname() to users of earlier versions of Python"
-HOMEPAGE = "https://pypi.python.org/pypi/backports.ssl_match_hostname"
-SECTION = "devel/python"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://PKG-INFO;md5=77b684960b86b7a4bb4a450ffde08605"
-SRCNAME = "backports.ssl_match_hostname"
-
-SRC_URI = "https://pypi.python.org/packages/source/b/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
SRC_URI[md5sum] = "788214f20214c64631f0859dc79f23c6"
SRC_URI[sha256sum] = "07410e7fb09aab7bdaf5e618de66c3dac84e2e3d628352814dc4c37de321d6ae"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
+PYPI_PACKAGE = "backports.ssl_match_hostname"
+inherit pypi setuptools