aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/gyp
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-10 21:28:03 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-11 21:21:13 -0800
commitb877b1938121b4f196133079d52131e669f4e15b (patch)
tree1abd2e0e0d102f0103baf4344bc3e65fe6d3e436 /meta-python/recipes-devtools/gyp
parentc278b7019886d8ea4fed29790f94c6a4c6b7aa84 (diff)
downloadmeta-openembedded-contrib-b877b1938121b4f196133079d52131e669f4e15b.tar.gz
gyp: provide a python2 version of gyp as gyp-py2
Doing so will allow us to change the NodeJS build to use the system gyp, rather than its own copy. NodeJS still uses python2, and imports parts of gyp directly. Also note that Debian only provides a python2 version. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/gyp')
-rw-r--r--meta-python/recipes-devtools/gyp/gyp-py2_git.bb2
-rw-r--r--meta-python/recipes-devtools/gyp/gyp.inc13
-rw-r--r--meta-python/recipes-devtools/gyp/gyp_git.bb15
3 files changed, 16 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/gyp/gyp-py2_git.bb b/meta-python/recipes-devtools/gyp/gyp-py2_git.bb
new file mode 100644
index 0000000000..d69b92ce6c
--- /dev/null
+++ b/meta-python/recipes-devtools/gyp/gyp-py2_git.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require gyp.inc
diff --git a/meta-python/recipes-devtools/gyp/gyp.inc b/meta-python/recipes-devtools/gyp/gyp.inc
new file mode 100644
index 0000000000..98ed42cc90
--- /dev/null
+++ b/meta-python/recipes-devtools/gyp/gyp.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
+HOMEPAGE = "https://gyp.gsrc.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
+SECTION = "devel"
+
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-python/recipes-devtools/gyp/gyp_git.bb
index 61f3c86370..8e48a27fae 100644
--- a/meta-python/recipes-devtools/gyp/gyp_git.bb
+++ b/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -1,15 +1,2 @@
-DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
-HOMEPAGE = "https://gyp.gsrc.io/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
-SECTION = "devel"
-
-SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
-SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
-
-S = "${WORKDIR}/git"
-PV = "0.1+git${SRCPV}"
-
inherit setuptools3
-
-BBCLASSEXTEND = "native nativesdk"
+require gyp.inc