aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/gyp
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-20 12:45:37 +0000
committerKhem Raj <raj.khem@gmail.com>2019-03-21 05:56:21 -0700
commiteed2859e3672ad05f5ce747c780aec09bfa64d92 (patch)
tree9ad863d260ab7a14e1bc42b441dfd1be3e1f9812 /meta-python/recipes-devtools/gyp
parent3a9b5f466f1f2f10514c5b3a11f15be74e8e4c71 (diff)
downloadmeta-openembedded-contrib-eed2859e3672ad05f5ce747c780aec09bfa64d92.tar.gz
gyp: add recipe
GYP (Generate Your Projects) is a meta-build system by Google. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/gyp')
-rw-r--r--meta-python/recipes-devtools/gyp/gyp_git.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-python/recipes-devtools/gyp/gyp_git.bb
new file mode 100644
index 0000000000..2b3f3fb2bf
--- /dev/null
+++ b/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
+HOMEPAGE = "https://gyp.gsrc.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
+SECTION = "devel"
+
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRCREV = "8bee09f4a57807136593ddc906b0b213c21f9014"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
+inherit setuptools3
+
+BBCLASSEXTEND = "native nativesdk"