aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-core/images
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-01-12 13:31:26 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-13 07:51:58 -0800
commit5b8f0a7085ce9947106aaf6eed58ebd7788677df (patch)
tree802616c4b6e3da076a849f7517b2e993dfa96776 /meta-python/recipes-core/images
parentcb631fe003ea733af95ba5e8959282667da0e244 (diff)
downloadmeta-openembedded-contrib-5b8f0a7085ce9947106aaf6eed58ebd7788677df.tar.gz
meta-python: add pkg groups and image for testing
Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-core/images')
-rw-r--r--meta-python/recipes-core/images/meta-python-image-base.bb7
-rw-r--r--meta-python/recipes-core/images/meta-python-image.bb6
-rw-r--r--meta-python/recipes-core/images/meta-python-ptest-image.bb5
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-core/images/meta-python-image-base.bb b/meta-python/recipes-core/images/meta-python-image-base.bb
new file mode 100644
index 0000000000..81081e61b2
--- /dev/null
+++ b/meta-python/recipes-core/images/meta-python-image-base.bb
@@ -0,0 +1,7 @@
+SUMMARY = "meta-python build test image"
+
+IMAGE_INSTALL = "packagegroup-core-boot"
+
+LICENSE = "MIT"
+
+inherit core-image
diff --git a/meta-python/recipes-core/images/meta-python-image.bb b/meta-python/recipes-core/images/meta-python-image.bb
new file mode 100644
index 0000000000..cc75fe6e4b
--- /dev/null
+++ b/meta-python/recipes-core/images/meta-python-image.bb
@@ -0,0 +1,6 @@
+require meta-python-image-base.bb
+
+SUMMARY = "meta-python build test image"
+
+IMAGE_INSTALL += "packagegroup-meta-python \
+ packagegroup-meta-python3"
diff --git a/meta-python/recipes-core/images/meta-python-ptest-image.bb b/meta-python/recipes-core/images/meta-python-ptest-image.bb
new file mode 100644
index 0000000000..7ee15354a2
--- /dev/null
+++ b/meta-python/recipes-core/images/meta-python-ptest-image.bb
@@ -0,0 +1,5 @@
+require meta-python-image-base.bb
+
+SUMMARY = "meta-python ptest test image"
+
+IMAGE_INSTALL += "packagegroup-meta-python-ptest"