aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-01-20 20:17:49 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit1ae31787167240729a78a442a378ef354583c012 (patch)
treea710e2846481058f4743c7f6d3745915116566e7 /meta-python/recipes-connectivity
parent05d0c5eee319055816bbea8b9dd972f723f68019 (diff)
downloadmeta-openembedded-contrib-1ae31787167240729a78a442a378ef354583c012.tar.gz
meta-python: rename python2 recipes to python3 eqiuvalent
Rename recipes which were previously built with python2 to their python3 equivalents. Use new python3 classes (setuptools3) in those recipes. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.77.bb (renamed from meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb)2
-rw-r--r--meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb (renamed from meta-python/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb)2
-rw-r--r--meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb (renamed from meta-python/recipes-connectivity/python-txws/python-txws_0.9.1.bb)2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb b/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.77.bb
index 738cf86774..f9dd9300b0 100644
--- a/meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb
+++ b/meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.77.bb
@@ -7,7 +7,7 @@ SRC_URI[sha256sum] = "2bfe12a22f396474b0e57c898c7e2c561a8f850bf2055d8cf0f7119f0c
PYPI_PACKAGE = "Pyro4"
-inherit pypi setuptools
+inherit pypi setuptools3
RDEPENDS_${PN} += " \
${PYTHON_PN}-logging \
diff --git a/meta-python/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb b/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb
index 2d51619d49..80f1a50178 100644
--- a/meta-python/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
+++ b/meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e95cd2f17c70d3180a2b361332319fe0"
SRC_URI[md5sum] = "c3bc8d9a910d2c9ce26f2ad1f7c96762"
SRC_URI[sha256sum] = "9af1c86bf73433afc6010ed376a6c6aca2b54099cc0d61895f640870a9ae7d89"
-inherit pypi setuptools
+inherit pypi setuptools3
# Use different filename to prevent conflicts with thrift itself
PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
diff --git a/meta-python/recipes-connectivity/python-txws/python-txws_0.9.1.bb b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
index f3631cda34..6d1327ac42 100644
--- a/meta-python/recipes-connectivity/python-txws/python-txws_0.9.1.bb
+++ b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
@@ -11,5 +11,5 @@ SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
S = "${WORKDIR}/git"
-inherit setuptools
+inherit setuptools3