aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-01-20 20:17:49 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit1ae31787167240729a78a442a378ef354583c012 (patch)
treea710e2846481058f4743c7f6d3745915116566e7 /meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
parent05d0c5eee319055816bbea8b9dd972f723f68019 (diff)
downloadmeta-openembedded-contrib-1ae31787167240729a78a442a378ef354583c012.tar.gz
meta-python: rename python2 recipes to python3 eqiuvalent
Rename recipes which were previously built with python2 to their python3 equivalents. Use new python3 classes (setuptools3) in those recipes. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb')
-rw-r--r--meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
new file mode 100644
index 0000000000..6d1327ac42
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Twisted Web Sockets"
+HOMEPAGE = "https://github.com/MostAwesomeDude/txWS"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=76699830db7fa9e897f6a1ad05f98ec8"
+
+DEPENDS = "python-twisted python-six python-vcversioner python-six-native python-vcversioner-native"
+
+SRC_URI = "git://github.com/MostAwesomeDude/txWS.git"
+SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+