aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:06 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit2c5208a9b1ac84c09abde03a0ab5b69237dc1e37 (patch)
treefd7dc1835b92d5752fe7b3edb151fc2f0e186c70 /meta-perl
parente08f0af9c423a07a213074903dbc72fd05385163 (diff)
downloadmeta-openembedded-contrib-2c5208a9b1ac84c09abde03a0ab5b69237dc1e37.tar.gz
libterm-readkey-perl: upgrade 2.37 -> 2.38; fix upstream check; enable ptest
Upstream release notes: """ 2.38 - 2019-01-05 * Bundle up various changes including: * Indexing improvements * Makefile improvements for some make utils * Various code cleanups and modernizations """ * Add UPSTREAM_CHECK_REGEX * Add UPSTREAM_CHECK_URI * inherit ptest-perl; all tests pass * ptest RDEPENDS on perl-module-test-more Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb (renamed from meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.37.bb)17
1 files changed, 12 insertions, 5 deletions
diff --git a/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.37.bb b/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb
index 6b76682c68..cc1ac6ed56 100644
--- a/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.37.bb
+++ b/meta-perl/recipes-perl/libterm/libterm-readkey-perl_2.38.bb
@@ -3,8 +3,8 @@ DESCRIPTION = "Term::ReadKey is a compiled perl module dedicated to providing si
control over terminal driver modes (cbreak, raw, cooked, etc.,) support \
for non-blocking reads, if the architecture allows, and some generalized \
handy functions for working with terminals. One of the main goals is to \
-have the functions as portable as possible, so you can just plug in "use \
-Term::ReadKey" on any architecture and have a good likelihood of it \
+have the functions as portable as possible, so you can just plug in 'use \
+Term::ReadKey' on any architecture and have a good likelihood of it \
working."
HOMEPAGE = "http://search.cpan.org/~jstowe/TermReadKey-${PV}"
SECTION = "libraries"
@@ -14,16 +14,23 @@ LIC_FILES_CHKSUM = "file://README;md5=c275db663c8489a5709ebb22b185add5"
SRC_URI = "${CPAN_MIRROR}/authors/id/J/JS/JSTOWE/TermReadKey-${PV}.tar.gz"
-SRC_URI[md5sum] = "e8ea15c16333ac4f8d146d702e83cc0c"
-SRC_URI[sha256sum] = "4a9383cf2e0e0194668fe2bd546e894ffad41d556b41d2f2f577c8db682db241"
+SRC_URI[md5sum] = "b2b4aab7a0e6bddb7ac3b21ba637482c"
+SRC_URI[sha256sum] = "5a645878dc570ac33661581fbb090ff24ebce17d43ea53fd22e105a856a47290"
S = "${WORKDIR}/TermReadKey-${PV}"
+UPSTREAM_CHECK_URI = "https://metacpan.org/release/TermReadKey"
+UPSTREAM_CHECK_REGEX = "TermReadKey\-(?P<pver>(\d+\.\d+))(?!_\d+)\.tar.gz"
+
# It needs depend on native to let dynamic loader use native modules
# rather than target ones.
DEPENDS = "libterm-readkey-perl-native"
-inherit cpan
+inherit cpan ptest-perl
+
+RDEPENDS_${PN}-ptest += " \
+ perl-module-test-more \
+"
do_configure_append () {
# Hack the dynamic module loader so that it use native modules since it can't load