aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:11 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commitb86d2d057d6106791537aaaead49f78de8512d26 (patch)
treeec7c98429e29e6d811f459dd0c6c253c58d9e71e /meta-perl
parentc34d38d716707f250af1945a0d65285c1958b2ae (diff)
downloadmeta-openembedded-contrib-b86d2d057d6106791537aaaead49f78de8512d26.tar.gz
libcrypt-openssl-random-perl: upgrade 0.11 -> 0.15; enable ptest
* Add EXTRA_CPANFLAGS to fix "undefined symbol: RAND_seed" * Add DEPENDS on libcrypt-openssl-guess-perl-native * Add runtime and ptest dependencies Upstream release notes: 0.15 2018-04-22 rurban - fix mingw hints for pkg-config support (akiym, PR #7) 0.14 2018-04-17 rurban - add library paths to LIBS from Crypt::OpenSSL::Guess (akiym, PR #6) 0.13 2018-04-14 rurban - move Crypt::OpenSSL::Guess to configure dependency. (grinnz, PR #4) 0.12 2018-04-13 rurban - use Crypt::OpenSSL::Guess to resolve OpenSSL include path, fixes MacOS's homebrew OpenSSL installation problem. (akiym, PR #3) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb15
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb34
2 files changed, 34 insertions, 15 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb
deleted file mode 100644
index 8456e313df..0000000000
--- a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.11.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "Crypt Openssl Random cpan module"
-SECTION = "libs"
-LICENSE = "Artistic-1.0 | GPL-1.0+"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=089c18d635ae273e1727ec385e64063b"
-
-SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Random-${PV}.tar.gz "
-SRC_URI[md5sum] = "5d71337503e0356ce1ce1481504e5885"
-SRC_URI[sha256sum] = "bb8c81c6a39b9b13a22d818ee9a746242f136f0fadceb6b9776ae615e7524c7a"
-
-S = "${WORKDIR}/Crypt-OpenSSL-Random-${PV}"
-
-DEPENDS += " openssl \
-"
-inherit cpan
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb
new file mode 100644
index 0000000000..a2ebb8c7a1
--- /dev/null
+++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-random-perl_0.15.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Crypt::OpenSSL::Random - OpenSSL/LibreSSL pseudo-random number generator access"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=089c18d635ae273e1727ec385e64063b"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Random-${PV}.tar.gz "
+SRC_URI[md5sum] = "bcde8d5a822c91376deda3c4f0c75fbe"
+SRC_URI[sha256sum] = "f0876faa1ba3111e39b86aa730c603211eff2905e460c72a57b61e8cf475cef4"
+
+S = "${WORKDIR}/Crypt-OpenSSL-Random-${PV}"
+
+DEPENDS += " \
+ openssl \
+ libcrypt-openssl-guess-perl-native \
+"
+
+EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -L${STAGING_BASELIBDIR} -lcrypto'"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN} += "\
+ perl-module-exporter \
+ perl-module-strict \
+ perl-module-vars \
+ perl-module-xsloader \
+"
+
+RDEPENDS_${PN}-ptest += "\
+ perl-module-file-copy \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"