aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-28 15:24:27 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:37:20 -0700
commit9070ae84822582957bfe199fd215c3cbd52d6eba (patch)
treeda88953ec4a117f7b42166f32107b79fbe6fed44 /meta-perl
parent1fd61636f9f6451b63b879ed34b8b3eff4c67d45 (diff)
downloadmeta-openembedded-contrib-9070ae84822582957bfe199fd215c3cbd52d6eba.tar.gz
libnet-ssleay-perl: Fix configure issue
Fix libnet-ssleay-perl tries to execute found openssl binaries at the place of ${OPENSSL_PREFIX} and bailing out when either binaries are missing or can't be executed. From cross-compiling perspective, both is insane. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch33
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb8
2 files changed, 38 insertions, 3 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch
new file mode 100644
index 0000000000..6efa7d8f95
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl/no-exec-on-configure.patch
@@ -0,0 +1,33 @@
+--- a/inc/Module/Install/PRIVATE/Net/SSLeay.pm 2018-08-27 14:56:24.788544991 +0200
++++ b/inc/Module/Install/PRIVATE/Net/SSLeay.pm 2018-08-27 15:00:12.847266331 +0200
+@@ -24,20 +24,7 @@
+ $self->requires_external_cc;
+
+ my $prefix = $self->find_openssl_prefix;
+- my $exec = $self->find_openssl_exec($prefix);
+-
+- unless (-x $exec) {
+- print <<EOM;
+-*** Could not find OpenSSL
+- If it's already installed, please set the OPENSSL_PREFIX environment
+- variable accordingly. If it isn't installed yet, get the latest version
+- from http://www.openssl.org/.
+-EOM
+- exit 0; # according http://wiki.cpantesters.org/wiki/CPANAuthorNotes this is best-practice when "missing library"
+- }
+-
+- $self->check_openssl_version($prefix, $exec);
+- my $opts = $self->ssleay_get_build_opts($prefix, $exec);
++ my $opts = $self->ssleay_get_build_opts($prefix);
+
+ $self->makemaker_args(
+ CCCDLFLAGS => $opts->{cccdlflags},
+@@ -58,7 +45,7 @@
+ }
+
+ sub ssleay_get_build_opts {
+- my ($self, $prefix, $exec) = @_;
++ my ($self, $prefix) = @_;
+
+ my $opts = {
+ lib_links => [],
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb
index a0bb90e7d6..dccef16404 100644
--- a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb
+++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.85.bb
@@ -23,6 +23,7 @@ RDEPENDS_${PN} += "\
"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
+ file://no-exec-on-configure.patch \
file://run-ptest \
"
SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69"
@@ -32,9 +33,10 @@ S = "${WORKDIR}/Net-SSLeay-${PV}"
inherit cpan ptest
-export OPENSSL_PREFIX="${STAGING_LIBDIR}"
-
-EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS='-L${STAGING_LIBDIR} -lcrypto -lssl -L${STAGING_BASELIBDIR} -lz'"
+do_configure() {
+ export OPENSSL_PREFIX="${STAGING_EXECPREFIXDIR}"
+ cpan_do_configure
+}
do_install_ptest() {
cp -r ${B}/t ${D}${PTEST_PATH}