aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:17 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit46b52235a3d662731cecc96195e3326f4e15e6a3 (patch)
treee147d67d31c27ec1a985f7981a252c92fa024dd5 /meta-perl
parentbc9447a9b30cf7bad8067aa91f297d46e3ceb5b3 (diff)
downloadmeta-openembedded-contrib-46b52235a3d662731cecc96195e3326f4e15e6a3.tar.gz
libxml-libxml-perl: enable ptest
Enable ptest and add ptest dependencies Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb26
1 files changed, 25 insertions, 1 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
index 9753520ae4..6fabf26840 100644
--- a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
+++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb
@@ -35,7 +35,7 @@ SRC_URI[libxml.sha256sum] = "f0bca4d0c2da35d879fee4cd13f352014186cedab27ab5e191f
S = "${WORKDIR}/XML-LibXML-${PV}"
-inherit cpan
+inherit cpan ptest-perl
EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
@@ -45,3 +45,27 @@ CFLAGS += " -D_GNU_SOURCE "
BUILD_CFLAGS += " -D_GNU_SOURCE "
FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"
+
+RDEPENDS_${PN}-ptest += " \
+ liburi-perl \
+ perl-module-encode-byte \
+ perl-module-encode-unicode \
+ perl-module-locale \
+ perl-module-perlio-scalar \
+ perl-module-test-more \
+"
+
+do_install_prepend() {
+ # test requires "-T" (taint) command line option
+ rm -rf ${B}/t/pod.t
+ # this only applies to author build
+ rm -rf ${B}/t/pod-files-presence.t
+}
+
+do_install_ptest() {
+ cp -r ${B}/t/data ${D}${PTEST_PATH}/t/
+ cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/
+ cp -r ${B}/example ${D}${PTEST_PATH}
+ cp -r ${B}/test ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}
+}