aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:09 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit30da5aa95934fae265a8c442ad9568bdedda28a1 (patch)
treee7ff41b28d1142fb57e0912c8450f2275cdd9ea8 /meta-perl
parentef2241ac3e3ef3ae8b21a4fc954e843da23881f8 (diff)
downloadmeta-openembedded-contrib-30da5aa95934fae265a8c442ad9568bdedda28a1.tar.gz
libcrypt-openssl-guess-perl: rename from libcrypt-openssl-guess; enable ptest
We follow Debian naming and this module snuck in misnamed. Add PROVIDES "libcrypt-openssl-guess" for backwards compatibility. Add runtime and ptest dependencies. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess-perl_0.11.bb (renamed from meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb)20
1 files changed, 18 insertions, 2 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess-perl_0.11.bb
index 21be047206..57df78b4e1 100644
--- a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb
+++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess-perl_0.11.bb
@@ -10,12 +10,28 @@ SRC_URI[sha256sum] = "aa6b18e38cb852cbad80a58cd90c395b40819d4d01e0ab37e770314909
DEPENDS += "openssl"
-RDEPENDS_${PN}="perl-module-config perl-module-exporter perl-module-symbol perl-module-file-spec"
+RDEPENDS_${PN} = "\
+ perl-module-config \
+ perl-module-exporter \
+ perl-module-extutils-mm \
+ perl-module-extutils-mm-unix \
+ perl-module-file-spec \
+ perl-module-symbol \
+ perl-module-strict \
+ perl-module-warnings \
+"
EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
-inherit cpan
+inherit cpan ptest-perl
BBCLASSEXTEND = "native"
+
+# for backwards compatibility
+PROVIDES_${PN} += "libcrypt-openssl-guess"
+
+RDEPENDS_${PN}-ptest += "\
+ perl-module-test-more \
+"