aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-08-13 21:15:26 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:28 +0200
commit8571e98823b96d0223c7abd90059b567b3217ee0 (patch)
tree8d03a5b903ea08d344e3167efe1107fad2b62ff2 /meta-perl
parentf3ac34f3d0243a5add8d4b839335b10ca1d8cdbb (diff)
downloadmeta-openembedded-contrib-8571e98823b96d0223c7abd90059b567b3217ee0.tar.gz
libextutils-parsexs-perl: add 3.24 recipe
Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb b/meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb
new file mode 100644
index 0000000000..1566f75be5
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb
@@ -0,0 +1,47 @@
+SUMMARY = "ExtUtils::ParseXS - converts Perl XS code into C code"
+DESCRIPTION = "\"ExtUtils::ParseXS\" will compile XS code into C code by \
+embedding the constructs necessary to let C functions manipulate Perl \
+values and creates the glue necessary to let Perl access those functions. \
+The compiler uses typesmapes to determine how to map C function parameters \
+and variables to Perl values."
+
+SECTION = "libs"
+
+HOMEPAGE = "http://metapan.org/release/ExtUtils-ParseXS/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=121;endline=130;md5=10ddb3a673b4c732022ac899968ea9cc"
+
+SRCNAME = "ExtUtils-ParseXS"
+SRC_URI = "${CPAN_MIRROR}/authors/id/S/SM/SMUELLER/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "e6be3f1d493e04ed805576104cf4328b"
+SRC_URI[sha256sum] = "30b60b8208fc9b7746ed934b678bb9618a8f28994dae8774548353a7b550371e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-carp \
+ perl-module-cwd \
+ perl-module-dynaloader \
+ perl-module-extutils-cbuilder \
+ perl-module-extutils-makemaker \
+ perl-module-file-basename \
+ perl-module-file-spec \
+ perl-module-lib \
+ perl-module-symbol \
+ perl-module-test-more \
+"
+
+RPROVIDES_${PN} += " libextutils-parsexs-constants-perl \
+ libextutils-parsexs-countlines-perl \
+ libextutils-parsexs-eval-perl \
+ libextutils-parsexs-utilities-perl \
+ libextutils-typemaps-perl \
+ libextutils-typemaps-cmd-perl \
+ libextutils-typemaps-inputmap-perl \
+ libextutils-typemaps-outputmap-perl \
+ libextutils-typemaps-type-perl \
+"
+
+BBCLASSEXTEND = "native"