aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:15 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit67f94d63f47ee135e1223aeeb6bddd6d9930199f (patch)
tree6cad2fb6db17373cc81f10e6ac1bebc08a049329 /meta-perl/recipes-perl
parent4058e65f3c4e17ad04423f4c9edf8607fe6fdb4f (diff)
downloadmeta-openembedded-contrib-67f94d63f47ee135e1223aeeb6bddd6d9930199f.tar.gz
libhtml-parser-perl: enable ptest
Add runtime and ptest dependencies Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl')
-rw-r--r--meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb b/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
index e202de05a7..a4c69c97b8 100644
--- a/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
+++ b/meta-perl/recipes-perl/libhtml/libhtml-parser-perl_3.72.bb
@@ -16,10 +16,30 @@ S = "${WORKDIR}/HTML-Parser-${PV}"
EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
-inherit cpan
+inherit cpan ptest-perl
do_compile() {
export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
cpan_do_compile
}
+
+RDEPENDS_${PN} += "\
+ perl-module-exporter \
+ perl-module-strict \
+ perl-module-vars \
+ perl-module-xsloader \
+ libhtml-tagset-perl \
+"
+
+RDEPENDS_${PN}-ptest += "\
+ liburi-perl \
+ perl-module-config \
+ perl-module-file-spec \
+ perl-module-filehandle \
+ perl-module-io-file \
+ perl-module-selectsaver \
+ perl-module-test \
+ perl-module-test-more \
+"
+
BBCLASSEXTEND = "native"