aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libtest/libtest-deep-perl_1.204.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-24 08:27:46 +0800
committerKhem Raj <raj.khem@gmail.com>2023-03-23 21:46:12 -0700
commit0ec7415e00cefc8d085dbc095a97d05cc527ff51 (patch)
tree1374a461c4df5def63312349c45812a5276423d0 /meta-perl/recipes-perl/libtest/libtest-deep-perl_1.204.bb
parent3525d4bb5a1989a1dee8efd83dad046f46f9b8c1 (diff)
downloadmeta-openembedded-contrib-0ec7415e00cefc8d085dbc095a97d05cc527ff51.tar.gz
libtest-deep-perl: upgrade 1.130 -> 1.204
License-Update: dzilification cleanup: remove redundant pod Changelog: ========== - restore v5.12 compatibility (see commit 66b79eb for the amusing anecdote) - try to avoid clobbering global error variables when loading test libraries (thanks, Felipe Gasper) - hash_each now enumates keys in sort() order, to make errors more consistent - no changes since trial releases - Test::Deep now requires perl v5.12. - correct Changes entry about which version version of perl is required - converted to Dist::Zilla - Test::Deep will now require v5.12, and this may go up. This change allows simplification of the Makefile.PL, which was coping with a mistake made twelve years ago. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libtest/libtest-deep-perl_1.204.bb')
-rw-r--r--meta-perl/recipes-perl/libtest/libtest-deep-perl_1.204.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libtest/libtest-deep-perl_1.204.bb b/meta-perl/recipes-perl/libtest/libtest-deep-perl_1.204.bb
new file mode 100644
index 0000000000..d7f6166b4b
--- /dev/null
+++ b/meta-perl/recipes-perl/libtest/libtest-deep-perl_1.204.bb
@@ -0,0 +1,55 @@
+SUMMARY = "Test::Deep - Extremely flexible deep comparison"
+DESCRIPTION = "If you don't know anything about automated testing in Perl \
+then you should probably read about Test::Simple and Test::More before \
+preceding. Test::Deep uses the Test::Builder framework. \
+\
+Test::Deep gives you very flexible ways to check that the result you got is \
+the result you were expecting. At its simplest it compares two structures \
+by going through each level, ensuring that the values match, that arrays and \
+hashes have the same elements and that references are blessed into the \
+correct class. It also handles circular data structures without getting \
+caught in an infinite loop. \
+\
+Where it becomes more interesting is in allowing you to do something besides \
+simple exact comparisons. With strings, the \'eq\' operator checks that 2 \
+strings are exactly equal but sometimes that's not what you want. When you \
+don't know exactly what the string should be but you do know some things \
+about how it should look, \'eq\' is no good and you must use pattern matching \
+instead. Test::Deep provides pattern matching for complex data structures \
+distribution."
+
+SECTION = "libs"
+
+HOMEPAGE = "http://github.com/rjbs/Test-Deep/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+LIC_FILES_CHKSUM = "file://lib/Test/Deep.pm;beginline=1817;endline=1826;md5=d3ed382cc19bae8ead6076df35a43cbf"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Deep-${PV}.tar.gz"
+SRC_URI[sha256sum] = "b6591f6ccdd853c7efc9ff3c5756370403211cffe46047f082b1cd1611a84e5f"
+
+UPSTREAM_CHECK_REGEX = "Test\-Deep\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
+
+S = "${WORKDIR}/Test-Deep-${PV}"
+
+inherit cpan ptest-perl
+
+RDEPENDS:${PN} += " \
+ perl-module-dynaloader \
+ perl-module-exporter \
+ perl-module-fcntl \
+ perl-module-list-util \
+ perl-module-scalar-util \
+ perl-module-strict \
+ perl-module-vars \
+ perl-module-warnings \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ perl-module-if \
+ perl-module-lib \
+ perl-module-test-more \
+ perl-module-test-tester \
+"
+
+BBCLASSEXTEND = "native"