aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libmoo/libmoo-perl_2.003004.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-21 14:44:07 -0800
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:12 -0800
commit794ce4ddca357b25045606df0fb27c7630f020c8 (patch)
treedebdb3e833e9b3fcd8cdc45a845f9355e72a9caf /meta-perl/recipes-perl/libmoo/libmoo-perl_2.003004.bb
parent88bec5d71886ae5f05544948eb1a690885b20875 (diff)
downloadmeta-openembedded-contrib-794ce4ddca357b25045606df0fb27c7630f020c8.tar.gz
libmoo-perl: upgrade 2.003002 -> 2.003004
Changes: 2.003004 - 2017-12-01 - re-allow stubs for attribute parameters like isa or coerce (RT#123753) - fix accidentally removed space in coderef error message (GH#33) - fix test errors with old Carp versions 2.003003 - 2017-11-16 - test tweaks - fix handling of code refs stored directly in the stash (for perl 5.28) - consider inline packages with constants in them as being loaded - stubs will be treated as methods that exist when inflating to Moose - avoid loading overload.pm unless required Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libmoo/libmoo-perl_2.003004.bb')
-rw-r--r--meta-perl/recipes-perl/libmoo/libmoo-perl_2.003004.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmoo/libmoo-perl_2.003004.bb b/meta-perl/recipes-perl/libmoo/libmoo-perl_2.003004.bb
new file mode 100644
index 0000000000..a260ab87db
--- /dev/null
+++ b/meta-perl/recipes-perl/libmoo/libmoo-perl_2.003004.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Moo - Minimalist Object Orientation (with Moose compatibility)"
+DESCRIPTION = "This module us an extremely light-weight subset of \"Moose\" \
+optimised for rapid startup and \"pay only for what you use\"."
+
+SECTION = "libs"
+
+HOMEPAGE = "http://metapan.org/release/Moo/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=731;endline=776;md5=27efedd175eeaddbd18f4e3572bd72a8"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/Moo-${PV}.tar.gz"
+SRC_URI[md5sum] = "d4fcd0f240033198571fcc81ce7c5f15"
+SRC_URI[sha256sum] = "f8bbb625f8e963eabe05cff9048fdd72bdd26777404ff2c40bc690f558be91e1"
+
+S = "${WORKDIR}/Moo-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " libclass-method-modifiers-perl \
+ libdevel-globaldestruction-perl \
+ libmodule-runtime-perl \
+ librole-tiny-perl \
+ perl-module-constant \
+ perl-module-exporter \
+ perl-module-mro \
+ perl-module-scalar-util \
+"
+
+RPROVIDES_${PN} = " libmethod-inliner-perl \
+ libmethod-generate-accessor-perl \
+ libmethod-generate-buildall-perl \
+ libmethod-generate-constructor-perl \
+ libmethod-generate-demolishall-perl \
+ libmoo-perl \
+ libmoo-handlemoose-perl \
+ libmoo-handlemoose-fakemetaclass-perl \
+ libmoo-object-perl \
+ libmoo-role-perl \
+ libsub-defer-perl \
+ libsub-quote-perl \
+"
+
+BBCLASSEXTEND = "native"