aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.016.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-02-21 22:26:31 -0800
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:12:56 -0800
commitab30a887b2ff15b2c88f21609b65eb73bc992d54 (patch)
tree3d4ba753a9c4f3c38e7c543798efcaf5cd2c0f20 /meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.016.bb
parent78ebb631c86ab61ec3750db85e1ce0d42ce1a2de (diff)
downloadmeta-openembedded-contrib-ab30a887b2ff15b2c88f21609b65eb73bc992d54.tar.gz
libmodule-runtime-perl: upgrade to 0.016, use upstream
Upstream has fixed build system to use EUMM, so we no longer need the fix on github.com/moto-timo. Add UPSTREAM_CHECK_REGEX to ensure we catch future updates. Extended the license checksum to include the Copyright. The length of the README file has changed, so the checksum has changed. Verified that the license remains the same. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.016.bb')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.016.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.016.bb b/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.016.bb
new file mode 100644
index 0000000000..89f0f709aa
--- /dev/null
+++ b/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.016.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Module::Runtime - runtime module handling"
+DESCRIPTION = "The functions exported by this module deal with runtime \
+handling of Perl modules, which are normally handled at compile time. This \
+module avoids using any other modules, so that it can be used in low-level \
+infrastructure. \
+The parts of this module that work with module names apply the same syntax \
+that is used for barewords in Perl source. In principle this syntax can vary \
+between versions of Perl, and this module applies the syntax of the Perl on \
+which it is running. In practice the usable syntax hasn't changed yet, but \
+there's a good chance of it changing in Perl 5.18. \
+The functions of this module whose purpose is to load modules include \
+workarounds for three old Perl core bugs regarding require. These workarounds \
+are applied on any Perl version where the bugs exist, except for a case where \
+one of the bugs cannot be adequately worked around in pure Perl."
+SECTION = "libs"
+
+HOMEPAGE = "http://search.cpan.org/~zefram/Module-Runtime/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=36;endline=44;md5=9416434672a57853d6181f3da9094963"
+
+SRCNAME = "Module-Runtime"
+SRC_URI = "${CPAN_MIRROR}/authors/id/Z/ZE/ZEFRAM/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "d3d47222fa2e3dfcb4526f6cc8437b20"
+SRC_URI[sha256sum] = "68302ec646833547d410be28e09676db75006f4aa58a11f3bdb44ffe99f0f024"
+
+UPSTREAM_CHECK_REGEX = "Module\-Runtime\-(?P<pver>(\d+\.\d+)).tar"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-test-more \
+ perl-module-strict \
+"
+
+BBCLASSEXTEND = "native"