aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libdb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-perl/recipes-perl/libdb
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libdb')
-rw-r--r--meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.68.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.68.bb b/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.68.bb
index b52a366861..c328696b02 100644
--- a/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.68.bb
+++ b/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.68.bb
@@ -24,14 +24,14 @@ DEPENDS += "libdbi-perl-native"
inherit cpan ptest-perl
-RDEPENDS_${PN} += "libdbi-perl \
+RDEPENDS:${PN} += "libdbi-perl \
sqlite3 \
perl-module-constant \
perl-module-locale \
perl-module-tie-hash \
"
-do_install_append() {
+do_install:append() {
if [ ${PERL_DBM_TEST} = "1" ]; then
install -m 755 -D ${WORKDIR}/sqlite-perl-test.pl ${D}/${bindir}/sqlite-perl-test.pl
fi
@@ -42,7 +42,7 @@ do_install_ptest() {
chown -R root:root ${D}${PTEST_PATH}
}
-RDEPENDS_${PN}-ptest += " \
+RDEPENDS:${PN}-ptest += " \
libtest-nowarnings-perl \
perl-module-lib \
perl-module-encode \