aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-perl/recipes-extended
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-extended')
-rw-r--r--meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb8
-rw-r--r--meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb4
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb b/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb
index bb9faa2c05..38ef0f8dc8 100644
--- a/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb
+++ b/meta-perl/recipes-extended/logcheck/logcheck_1.3.23.bb
@@ -21,9 +21,9 @@ S = "${WORKDIR}/${BPN}"
inherit useradd
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \
+USERADD_PARAM:${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \
-s /bin/false -c 'logcheck account' ${BPN}"
-GROUPADD_PARAM_${PN} = "-r ${BPN}"
+GROUPADD_PARAM:${PN} = "-r ${BPN}"
do_install() {
# Fix QA Issue
@@ -62,7 +62,7 @@ do_install() {
VIRTUAL-RUNTIME_syslog ??= "rsyslog"
-RDEPENDS_${PN} = "\
+RDEPENDS:${PN} = "\
bash \
cronie \
debianutils-run-parts \
@@ -76,4 +76,4 @@ RDEPENDS_${PN} = "\
${VIRTUAL-RUNTIME_syslog} \
"
-FILES_${PN} += "${datadir}/logtail"
+FILES:${PN} += "${datadir}/logtail"
diff --git a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
index 2516fbfcaa..2919904572 100644
--- a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
+++ b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
@@ -17,11 +17,11 @@ SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a
inherit cpan
-RDEPENDS_${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \
+RDEPENDS:${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \
perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \
"
-do_install_append() {
+do_install:append() {
#change the interpreter in file
sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \
${D}/${bindir}/mime-construct