aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-01-12 11:25:05 +0800
committerKhem Raj <raj.khem@gmail.com>2021-01-11 19:40:31 -0800
commite64c674ce28fe72b536c0b4c59571069a32667f5 (patch)
treec284805929936e7692da6378caa5ef2d2d9dfdd1 /meta-oe
parent1368f33affeb5ecf75abc15b84fd5a4c55260c54 (diff)
downloadmeta-openembedded-contrib-e64c674ce28fe72b536c0b4c59571069a32667f5.tar.gz
mcelog: fix the pfa test hang
Per [1], the pfa test needs to install page-types and the pfa test will hang forever if there is no page-types installed. Improve the test script to avoid the pfa test hang. [1] https://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git/tree/tests/pfa/PFA_test_howto?id=7b776a8c005b60572f49797e81287540f99fff1f Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch36
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_170.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch b/meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch
new file mode 100644
index 0000000000..83c29a651f
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mcelog/0001-test-avoid-the-pfa-test-hang.patch
@@ -0,0 +1,36 @@
+From 139177715a2d66ccd3e099be5d9d4dc86db30055 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Tue, 12 Jan 2021 03:05:38 +0000
+Subject: [PATCH] test: avoid the pfa test hang
+
+Per [1], the pfa test needs to install page-types and the pfa test
+will hang forever if there is no page-types installed.
+
+Improve the test script to avoid the pfa test hang.
+
+[1] https://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git/tree/tests/pfa/PFA_test_howto?id=7b776a8c005b60572f49797e81287540f99fff1f
+
+Upstream-Status: Submitted [https://github.com/andikleen/mcelog/pull/87]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ tests/test | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tests/test b/tests/test
+index 9623f4a..7c552a9 100755
+--- a/tests/test
++++ b/tests/test
+@@ -45,6 +45,9 @@ for conf in `ls *.conf`
+ do
+ log=`echo $conf | sed "s/conf/log/g"`
+ ./inject $conf
++ if [ "$1" = "pfa" ] ; then
++ which page-types > /dev/null 2>&1 || continue
++ fi
+ $D ../../mcelog --foreground --daemon --debug-numerrors --config $conf --logfile $log >> result
+
+ # let triggers finish
+--
+2.29.2
+
diff --git a/meta-oe/recipes-support/mcelog/mcelog_170.bb b/meta-oe/recipes-support/mcelog/mcelog_170.bb
index bdb080f418..f3e018d4a8 100644
--- a/meta-oe/recipes-support/mcelog/mcelog_170.bb
+++ b/meta-oe/recipes-support/mcelog/mcelog_170.bb
@@ -6,6 +6,7 @@ HOMEPAGE = "http://mcelog.org/"
SECTION = "System Environment/Base"
SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
+ file://0001-test-avoid-the-pfa-test-hang.patch \
file://run-ptest \
"