aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorYoann Congal <yoann.congal@smile.fr>2024-03-05 16:27:59 +0100
committerKhem Raj <raj.khem@gmail.com>2024-03-05 11:02:04 -0800
commite317b01690b9f5c1a98e9c8a70097d0db6f0cb09 (patch)
tree584ad57b635224a31a7370b804a54daf85ec530b /meta-oe
parent6757155f09a275771f26c209ad4559f152d7b7da (diff)
downloadmeta-openembedded-contrib-e317b01690b9f5c1a98e9c8a70097d0db6f0cb09.tar.gz
toybox-inittab: Fix serial getty reproducibility
The enable_getty test uses a bash-only syntax "[[ ... ]]". On /bin/sh==bash hosts, it enables the serial getty. On /bin/sh!=bash hosts, it does not enable it. Fix this non-reproducibility by using the standard shell "[ ... ]" syntax which should work in any POSIX shell[0]. [0]: https://www.shellcheck.net/wiki/SC3010 Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
index 603f365cf3..4cad7dce11 100644
--- a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
+++ b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
@@ -34,7 +34,7 @@ do_configure() {
cp orig/* .
for config in ${PACKAGECONFIG_CONFARGS}; do
- if [[ ${config} == "enable_getty" ]]; then
+ if [ "${config}" = "enable_getty" ]; then
echo "# generated by bitbake recipe ${PN}" >> ${S}/inittab
for console in "${SERIAL_CONSOLES}"; do
param=$(echo ${console} | sed s/\;/\ /g)