aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2024-03-07 11:21:05 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:26 -0800
commitbf30c08dd568edf0fe2e910efe228958b1afa1a3 (patch)
tree8f01e321cc27237bfdfe5834f6643fe92f1fd77d /meta-oe
parentbe06d51d61361b4d09cd943fb0e6248089073bd5 (diff)
downloadmeta-openembedded-contrib-bf30c08dd568edf0fe2e910efe228958b1afa1a3.tar.gz
re2: Upgrade 2023.03.01 -> 2024.03.01
1, Add abseil-cpp, gtest and benchmark to DEPENDS to fix the below kind configure error. CMake Error at CMakeLists.txt:81 (find_package): By not providing "Findabsl.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "absl", but CMake did not find one. Could not find a package configuration file provided by "absl" with any of the following names: abslConfig.cmake absl-config.cmake 2, Install libtesting.so to target to fix the below QA issue. ERROR: re2-2024.03.01-r0 do_package_qa: QA Issue: /usr/lib64/re2/ptest/string_generator_test contained in package re2-ptest requires libtesting.so()(64bit), but no providers found in RDEPENDS:re2-ptest? [file-rdeps] 3, Add abseil-cpp-dev to RDEPENDS to fix the below QA issue. ERROR: re2-2024.03.01-r0 do_package_qa: QA Issue: re2 rdepends on abseil-cpp-dev [dev-deps] 4, The ptest output as below: # ./run-ptest PASS: charclass_test PASS: compile_test PASS: filtered_re2_test PASS: mimics_pcre_test PASS: parse_test PASS: possible_match_test PASS: re2_test PASS: re2_arg_test PASS: regexp_test PASS: required_prefix_test PASS: search_test PASS: set_test PASS: simplify_test PASS: string_generator_test PASS: dfa_test PASS: exhaustive1_test PASS: exhaustive2_test PASS: exhaustive3_test PASS: exhaustive_test PASS: random_test Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/re2/re2_2024.03.01.bb (renamed from meta-oe/recipes-support/re2/re2_2023.03.01.bb)13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/re2/re2_2023.03.01.bb b/meta-oe/recipes-support/re2/re2_2024.03.01.bb
index fe210d5107..192fe265f1 100644
--- a/meta-oe/recipes-support/re2/re2_2023.03.01.bb
+++ b/meta-oe/recipes-support/re2/re2_2024.03.01.bb
@@ -3,8 +3,8 @@ HOMEPAGE = "https://github.com/google/re2/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b5c31eb512bdf3cb11ffd5713963760"
-# tag 2023-03-01
-SRCREV = "241e2e430836e80f93d704d1f06cd3e7fe3100f5"
+# tag 2024-03-01
+SRCREV = "2d866a3d0753f4f4fce93cccc6c59c4b052d7db4"
SRC_URI = "git://github.com/google/re2.git;branch=main;protocol=https \
${@bb.utils.contains('PTEST_ENABLED', '1', 'file://run-ptest', '', d)} \
@@ -12,12 +12,17 @@ SRC_URI = "git://github.com/google/re2.git;branch=main;protocol=https \
S = "${WORKDIR}/git"
+DEPENDS = "abseil-cpp ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest googlebenchmark', '', d)}"
+
inherit cmake ptest
RDEPENDS:${PN}-ptest += "cmake sed"
+RDEPENDS:${PN} += "abseil-cpp-dev"
+
+INSANE_SKIP:${PN} += "dev-deps"
EXTRA_OECMAKE += " \
-DBUILD_SHARED_LIBS=ON \
- ${@bb.utils.contains('PTEST_ENABLED', '1', '-DRE2_BUILD_TESTING=ON', '-DRE2_BUILD_TESTING=OFF', d)} \
+ ${@bb.utils.contains('PTEST_ENABLED', '1', '-DRE2_BUILD_TESTING=ON', '-DRE2_BUILD_TESTING=OFF', d)} \
"
do_install_ptest () {
@@ -25,6 +30,8 @@ do_install_ptest () {
cp -r ${B}/CTestTestfile.cmake ${D}${PTEST_PATH}
sed -i -e 's#${B}#${PTEST_PATH}#g' `find ${D}${PTEST_PATH} -name CTestTestfile.cmake`
sed -i -e 's#${S}#${PTEST_PATH}#g' `find ${D}${PTEST_PATH} -name CTestTestfile.cmake`
+ # ERROR: re2-2024.03.01-r0 do_package_qa: QA Issue: /usr/lib64/re2/ptest/string_generator_test contained in package re2-ptest requires libtesting.so()(64bit), but no providers found in RDEPENDS:re2-ptest? [file-rdeps]
+ cp -r ${B}/libtesting.so ${D}${PTEST_PATH}
}
# ignore .so in /usr/lib64