aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-03 08:17:46 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-03 11:23:41 -0700
commita6bcdca5b4681906b00e12f6bc4af465c85bad9f (patch)
tree71836252df81268e3171b08d0fc9558ba73a0201 /meta-oe
parenta8b2cdc20e184365701bcd8316956fd3fabf6425 (diff)
downloadmeta-openembedded-contrib-a6bcdca5b4681906b00e12f6bc4af465c85bad9f.tar.gz
highway,libjxl: Remove -mfp16-format=ieee when using clang compiler
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/highway/highway_1.1.0.bb2
-rw-r--r--meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb3
2 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/highway/highway_1.1.0.bb b/meta-oe/recipes-extended/highway/highway_1.1.0.bb
index ec9d8f742d..11d9e7cddf 100644
--- a/meta-oe/recipes-extended/highway/highway_1.1.0.bb
+++ b/meta-oe/recipes-extended/highway/highway_1.1.0.bb
@@ -13,3 +13,5 @@ S = "${WORKDIR}/git"
EXTRA_OECMAKE = "-DBUILD_TESTING=0 -DCMAKE_BUILD_TYPE=Release"
CXXFLAGS:append:arm = " -mfp16-format=ieee"
+# Option not supported with clang and its default format for __fp16 anyway with clang
+CXXFLAGS:remove:toolchain-clang = "-mfp16-format=ieee"
diff --git a/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb b/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
index 0c4f79fdb4..142b283614 100644
--- a/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
+++ b/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
@@ -39,4 +39,5 @@ PACKAGECONFIG[mime] = "-DJPEGXL_ENABLE_PLUGIN_MIME=ON,-DJPEGXL_ENABLE_PLUGIN_MIM
FILES:${PN} += "${libdir}/gdk-pixbuf-2.0 ${datadir}"
CXXFLAGS:append:arm = " -mfp16-format=ieee"
-
+# Option not supported with clang and its default format for __fp16 anyway with clang
+CXXFLAGS:remove:toolchain-clang = "-mfp16-format=ieee"