aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-08 08:15:10 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:28 -0800
commit903c8e58ed2240f7214261c9005a38f15d782c29 (patch)
tree0698567213d88fbfcf41d8de16822ae397adadb3 /meta-oe
parentd8511c2432ca4ba75bca6e7f71f3c4c3f6098aae (diff)
downloadmeta-openembedded-contrib-903c8e58ed2240f7214261c9005a38f15d782c29.tar.gz
abseil-cpp: upgrade 20230802.1 -> 20240116.1
0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch revmoed since it's included in 20240116.1. Changelog: =========== -Added absl::NoDestructor<T> to simplify defining static types that do not need to be destructed upon program exit. -Added configurable verbose logging (also known as VLOG). -Added absl::Overload(), which returns a functor that provides overloads based on the functors passed to it. -Bzlmod is now officially supported (previously it was supported by the community). Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch62
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb (renamed from meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb)37
2 files changed, 9 insertions, 90 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch
deleted file mode 100644
index db559bb161..0000000000
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From cb7665f39e23e95e2466390c60ee5a410780a3ed Mon Sep 17 00:00:00 2001
-From: Derek Mauro <dmauro@google.com>
-Date: Wed, 8 Nov 2023 09:55:31 -0800
-Subject: [PATCH] Avoid using both Win32Waiter and PthreadWaiter on MinGW, and
- use StdcppWaiter instead.
-
-There are various flavors of MinGW, some of which support pthread,
-and some of which support Win32. Instead of figuring out which
-platform is being used, just use the generic implementation.
-
-PiperOrigin-RevId: 580565507
-Change-Id: Ia85fd7496f1e6ebdeadb95202f0039e844826118
-Upstream-Status: Backport
----
- absl/synchronization/internal/pthread_waiter.h | 4 ++--
- absl/synchronization/internal/win32_waiter.h | 6 ++++--
- 2 files changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/absl/synchronization/internal/pthread_waiter.h b/absl/synchronization/internal/pthread_waiter.h
-index 206aefa4..23db76ad 100644
---- a/absl/synchronization/internal/pthread_waiter.h
-+++ b/absl/synchronization/internal/pthread_waiter.h
-@@ -16,7 +16,7 @@
- #ifndef ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
- #define ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
-
--#ifndef _WIN32
-+#if !defined(_WIN32) && !defined(__MINGW32__)
- #include <pthread.h>
-
- #include "absl/base/config.h"
-@@ -55,6 +55,6 @@ class PthreadWaiter : public WaiterCrtp<PthreadWaiter> {
- ABSL_NAMESPACE_END
- } // namespace absl
-
--#endif // ndef _WIN32
-+#endif // !defined(_WIN32) && !defined(__MINGW32__)
-
- #endif // ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
-diff --git a/absl/synchronization/internal/win32_waiter.h b/absl/synchronization/internal/win32_waiter.h
-index 87eb617c..fdab264e 100644
---- a/absl/synchronization/internal/win32_waiter.h
-+++ b/absl/synchronization/internal/win32_waiter.h
-@@ -20,7 +20,8 @@
- #include <sdkddkver.h>
- #endif
-
--#if defined(_WIN32) && _WIN32_WINNT >= _WIN32_WINNT_VISTA
-+#if defined(_WIN32) && !defined(__MINGW32__) && \
-+ _WIN32_WINNT >= _WIN32_WINNT_VISTA
-
- #include "absl/base/config.h"
- #include "absl/synchronization/internal/kernel_timeout.h"
-@@ -65,6 +66,7 @@ class Win32Waiter : public WaiterCrtp<Win32Waiter> {
- ABSL_NAMESPACE_END
- } // namespace absl
-
--#endif // defined(_WIN32) && _WIN32_WINNT >= _WIN32_WINNT_VISTA
-+#endif // defined(_WIN32) && !defined(__MINGW32__) &&
-+ // _WIN32_WINNT >= _WIN32_WINNT_VISTA
-
- #endif // ABSL_SYNCHRONIZATION_INTERNAL_WIN32_WAITER_H_
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb
index 17db7b2e44..82b2d20e08 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb
@@ -1,24 +1,26 @@
SUMMARY = "Abseil is a cpp library like STL"
DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
additional useful libraries like algorithm, container, debugging, hash, memory, \
-meta, numeric, strings, synchronization, time, types and utility."
+meta, numeric, strings, synchronization, time, types and utility"
HOMEPAGE = "https://abseil.io/"
SECTION = "libs"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
-SRCREV = "fb3621f4f897824c0dbe0615fa94543df6192f30"
-BRANCH = "lts_2023_08_02"
+SRCREV = "2f9e432cce407ce0ae50676696666f33a77d42ac"
+BRANCH = "lts_2024_01_16"
SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
file://0001-absl-always-use-asm-sgidefs.h.patch \
file://0002-Remove-maes-option-from-cross-compilation.patch \
file://abseil-ppc-fixes.patch \
file://0003-Remove-neon-option-from-cross-compilation.patch \
- file://0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch \
"
S = "${WORKDIR}/git"
+ASNEEDED:class-native = ""
+ASNEEDED:class-nativesdk = ""
+
inherit cmake
EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
@@ -26,29 +28,8 @@ EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
-DABSL_ENABLE_INSTALL=ON \
"
-SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
-
-PACKAGES_DYNAMIC = "^libabsl-*"
-PACKAGES_DYNAMIC:class-native = ""
-
-PACKAGESPLITFUNCS =+ "split_dynamic_packages"
-
-python split_dynamic_packages() {
- libdir = d.getVar('libdir')
-
- libpackages = do_split_packages(
- d,
- root=libdir,
- file_regex=r'^libabsl_(.*)\.so\..*$',
- output_pattern='libabsl-%s',
- description="abseil shared library %s",
- prepend=True,
- extra_depends='',
- )
- if libpackages:
- d.appendVar('RDEPENDS:' + d.getVar('PN'), ' ' + ' '.join(libpackages))
-}
+BBCLASSEXTEND = "native nativesdk"
-ALLOW_EMPTY:${PN} = "1"
+SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
-BBCLASSEXTEND = "native nativesdk"
+FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"