aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorDaniel Ammann <daniel.ammann@bytesatwork.ch>2024-02-26 12:45:32 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-26 08:14:43 -0800
commit89cd053863104685a5ca996174b0e197b93784de (patch)
treebe531255949874e8f6246c133dc5edf6afc50d72 /meta-oe
parent0e18a0cea962a187cffcca248b1685924742afd4 (diff)
downloadmeta-openembedded-contrib-89cd053863104685a5ca996174b0e197b93784de.tar.gz
sdmon: add new package
Signed-off-by: Daniel Ammann <daniel.ammann@bytesatwork.ch> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-support/sdmon/sdmon_git.bb20
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 740835b217..6e2012daea 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -874,6 +874,7 @@ RDEPENDS:packagegroup-meta-oe-support ="\
raptor2 \
rdfind \
re2 \
+ sdmon \
sdparm \
serial-forward \
read-edid \
diff --git a/meta-oe/recipes-support/sdmon/sdmon_git.bb b/meta-oe/recipes-support/sdmon/sdmon_git.bb
new file mode 100644
index 0000000000..522539a67b
--- /dev/null
+++ b/meta-oe/recipes-support/sdmon/sdmon_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Get SD card health data"
+HOMEPAGE = "https://github.com/Ognian/sdmon"
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/Ognian/sdmon;protocol=https;branch=master"
+
+PV = "0.8.1+git"
+SRCREV = "ef1aec457f04a50721f0259651cca9c946f11390"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake -C ${S}/src CC="${CC}" CFLAGS="${CFLAGS} -D_REENTRANT -DVERSION=\"\\\"${PV}\\\"\"" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ install -Dm 0755 ${S}/src/sdmon ${D}${bindir}/sdmon
+}