aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-09-30 18:25:43 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-19 09:23:08 -0700
commit74d38f9a31ba16c79c62e7175f57715a446dbc6a (patch)
treee9fab7a0848facaa6bc375f530ad008aad538857 /meta-oe
parentb890de3ed147f3ff812762be3bec3f80f64f6d70 (diff)
downloadmeta-openembedded-contrib-74d38f9a31ba16c79c62e7175f57715a446dbc6a.tar.gz
lv-lib-png: Add recipe for LVGL for handling PNG format
Note that this lib will be part of next lvgl release, meanwhile we build it without touching lvgl default config. Relate-to: https://git.ostc-eu.org/OSTC/planning/core-os/-/issues/233 Relate-to: https://github.com/lvgl/lvgl/issues/2534 Forwarded: https://github.com/openembedded/meta-openembedded/pull/454 Change-Id: I2e467caae8e70577e5c9a93f92efc6588cf3bfa2 Signed-off-by: Philippe Coval <philippe.coval@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
new file mode 100644
index 0000000000..ada9423076
--- /dev/null
+++ b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
@@ -0,0 +1,26 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+# SPDX-License-Identifier: MIT
+
+src_org = "lvgl"
+SRC_URI = "gitsm://github.com/${src_org}/lv_lib_png;destsuffix=${S};protocol=https;nobranch=1"
+SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
+
+HOMEPAGE = "https://docs.lvgl.io"
+SUMMARY = "PNG decoder for LVGL"
+DESCRIPTION = "Allow the use of PNG images in LVGL. This implementation uses lodepng"
+
+DEPENDS += "lvgl"
+
+inherit cmake
+
+TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
+TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
+
+FILES:${PN}-dev = "\
+ ${includedir}/lvgl/lv_lib_png/ \
+ "
+
+FILES:${PN}-staticdev = "${libdir}/"