aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-30 11:48:11 -0800
committerKhem Raj <raj.khem@gmail.com>2023-02-01 09:11:49 -0800
commit6e3b7aa52718cdba83c324ee9424f65dbe61748c (patch)
treedcd12bf82df5797e7098834806f283013de00b23 /meta-oe
parent6cdb98eed2d68cb99361776e8e926703d385984c (diff)
downloadmeta-openembedded-contrib-6e3b7aa52718cdba83c324ee9424f65dbe61748c.tar.gz
lcdproc: Update to latest tip of trunk
Drop patches already present in trunk as of now Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-compilation-with-GCC-10.x.patch39
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-parallel-build-fix-port-internal-make-dependenci.patch33
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0002-Include-limits.h-for-PATH_MAX-definition.patch41
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0003-Fix-non-x86-platforms-on-musl.patch49
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb9
5 files changed, 2 insertions, 169 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-compilation-with-GCC-10.x.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-compilation-with-GCC-10.x.patch
deleted file mode 100644
index cd8a69c3fb..0000000000
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-compilation-with-GCC-10.x.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 9b07f6a472c24f5e1b65746756764391be0d55e4 Mon Sep 17 00:00:00 2001
-From: Harald Geyer <harald@ccbib.org>
-Date: Mon, 10 Feb 2020 13:15:10 +0100
-Subject: [PATCH] Fix compilation with GCC >= 10.x
-
-Starting with GCC >= 10.x, -fno-common is used as default
-instead of -fcommon. This patch fixes the compilation.
-
-Closes: #148
-
-Upstream-Status: Backport
-Suggested-by: Conrad Kostecki <conrad@kostecki.com>
-Signed-off-by: Harald Geyer <harald@ccbib.org>
----
- clients/lcdproc/iface.c | 1 +
- clients/lcdproc/iface.h | 2 +-
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
---- a/clients/lcdproc/iface.c
-+++ b/clients/lcdproc/iface.c
-@@ -32,6 +32,7 @@
- #define UNSET_INT -1
- #define UNSET_STR "\01"
-
-+IfaceInfo iface[MAX_INTERFACES];
-
- static int iface_count = 0; /* number of interfaces */
- static char unit_label[10] = "B"; /* default unit label is Bytes */
---- a/clients/lcdproc/iface.h
-+++ b/clients/lcdproc/iface.h
-@@ -18,7 +18,7 @@
- /** max number of interfaces in multi-interface mode */
- #define MAX_INTERFACES 3
-
--IfaceInfo iface[MAX_INTERFACES]; /* interface info */
-+extern IfaceInfo iface[MAX_INTERFACES]; /* interface info */
-
- /** Update screen content */
- int iface_screen(int rep, int display, int *flags_ptr);
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-parallel-build-fix-port-internal-make-dependenci.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-parallel-build-fix-port-internal-make-dependenci.patch
deleted file mode 100644
index f6a7956db2..0000000000
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0001-Fix-parallel-build-fix-port-internal-make-dependenci.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From a20feee4963bc38975fbaf44bbe85a31825f59db Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 6 Apr 2019 17:28:28 -0700
-Subject: [PATCH 1/3] Fix parallel build (fix port-internal make dependencies)
- on many cores
-
-Upstream-Status: Submitted [https://github.com/lcdproc/lcdproc/pull/142]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- server/drivers/Makefile.am | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/server/drivers/Makefile.am b/server/drivers/Makefile.am
-index e08f2b2d..4fd2e3f1 100644
---- a/server/drivers/Makefile.am
-+++ b/server/drivers/Makefile.am
-@@ -47,11 +47,11 @@ CwLnx_LDADD = libLCD.a libbignum.a
- futaba_LDADD = @LIBUSB_LIBS@ @LIBUSB_1_0_LIBS@ libLCD.a
- g15_LDADD = @LIBG15@
- glcd_LDADD = libLCD.a @GLCD_DRIVERS@ @FT2_LIBS@ @LIBPNG_LIBS@ @LIBSERDISP@ @LIBUSB_LIBS@ @LIBX11_LIBS@
--glcd_DEPENDENCIES = @GLCD_DRIVERS@ glcd-glcd-render.o
-+glcd_DEPENDENCIES = @GLCD_DRIVERS@ glcd-glcd-render.o libLCD.a
- glcdlib_LDADD = @LIBGLCD@
- glk_LDADD = libbignum.a
- hd44780_LDADD = libLCD.a @HD44780_DRIVERS@ @HD44780_I2C@ @LIBUSB_LIBS@ @LIBFTDI_LIBS@ @LIBUGPIO@ libbignum.a
--hd44780_DEPENDENCIES = @HD44780_DRIVERS@ @HD44780_I2C@
-+hd44780_DEPENDENCIES = @HD44780_DRIVERS@ @HD44780_I2C@ libLCD.a libbignum.a
- i2500vfd_LDADD = @LIBFTDI_LIBS@
- imon_LDADD = libLCD.a libbignum.a
- imonlcd_LDADD = libLCD.a
---
-2.24.1
-
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0002-Include-limits.h-for-PATH_MAX-definition.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0002-Include-limits.h-for-PATH_MAX-definition.patch
deleted file mode 100644
index eb866bf10a..0000000000
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0002-Include-limits.h-for-PATH_MAX-definition.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From d447a05ee560ba5894d2ed4cd93d0475c2f3c08e Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 17 Dec 2019 17:39:32 -0800
-Subject: [PATCH 2/3] Include <limits.h> for PATH_MAX definition
-
-musl libc exposes the missing include
-
-Upstream-Status: Submitted [https://github.com/lcdproc/lcdproc/pull/142]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- server/drivers/hidraw_lib.c | 1 +
- server/drivers/linux_input.c | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/server/drivers/hidraw_lib.c b/server/drivers/hidraw_lib.c
-index 49b03f20..3b51f279 100644
---- a/server/drivers/hidraw_lib.c
-+++ b/server/drivers/hidraw_lib.c
-@@ -8,6 +8,7 @@
- #include <dirent.h>
- #include <errno.h>
- #include <fcntl.h>
-+#include <limits.h>
- #include <stdlib.h>
- #include <string.h>
- #include <sys/ioctl.h>
-diff --git a/server/drivers/linux_input.c b/server/drivers/linux_input.c
-index 5b914d4c..6fcfc591 100644
---- a/server/drivers/linux_input.c
-+++ b/server/drivers/linux_input.c
-@@ -5,6 +5,7 @@
-
- #include <dirent.h>
- #include <errno.h>
-+#include <limits.h>
- #include <stdint.h>
- #include <stdio.h>
- #include <stdlib.h>
---
-2.24.1
-
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0003-Fix-non-x86-platforms-on-musl.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0003-Fix-non-x86-platforms-on-musl.patch
deleted file mode 100644
index eed9ceee5e..0000000000
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc/0003-Fix-non-x86-platforms-on-musl.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 7fd144f101fa5c9316d3468ed26f55629afe1305 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 17 Dec 2019 17:55:54 -0800
-Subject: [PATCH 3/3] Fix non x86 platforms on musl
-
-Musl only specifies in/outb for x86/x86. Use the fallback path in case
-musl is used.
-
-This should fail compilation during the linking stage but for some reason
-does not. Will do if -Werror=implicit-function-declaration is specified.
-
-Original here: https://github.com/openwrt/packages/blob/master/utils/lcdproc/patches/110-in-outb.patch
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- server/drivers/port.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/server/drivers/port.h
-+++ b/server/drivers/port.h
-@@ -94,7 +94,7 @@ static inline int port_deny_multiple(uns
- /* ---------------------------- Linux ------------------------------------ */
- /* Use ioperm, inb and outb in <sys/io.h> (Linux) */
- /* And iopl for higher addresses of PCI LPT cards */
--#if defined HAVE_IOPERM
-+#if HAVE_INB
-
- /* Glibc2 and Glibc1 */
- # ifdef HAVE_SYS_IO_H
-@@ -333,7 +333,7 @@ static inline int port_deny_multiple (un
- return i386_set_ioperm(port, count, 0);
- }
-
--#else
-+#elif defined(__x86__) && defined(__x86_64__)
-
- /* ------------------------- Everything else ----------------------------- */
- /* Last chance! Use /dev/io and i386 ASM code (BSD4.3 ?) */
---- a/configure.ac
-+++ b/configure.ac
-@@ -144,6 +144,7 @@ AC_CHECK_LIB(i386, i386_get_ioperm,
- [])]
- )
-
-+AC_CHECK_FUNCS(inb)
- AC_CHECK_FUNCS(iopl)
- AC_CHECK_FUNCS(ioperm)
- AC_CHECK_HEADERS(sys/io.h)
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb
index 76a931666d..4cae4947f2 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/lcdproc/lcdproc_git.bb
@@ -10,13 +10,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
file://README.md;beginline=107;md5=5db392f043253a2d64b1737068ce6b58"
PV = "0.5.9+git${SRCPV}"
-SRCREV = "3a3d622d9bb74c44fa67bc20573751a207514134"
-SRC_URI = "git://github.com/lcdproc/lcdproc;branch=master;protocol=https \
- file://0001-Fix-parallel-build-fix-port-internal-make-dependenci.patch \
- file://0002-Include-limits.h-for-PATH_MAX-definition.patch \
- file://0003-Fix-non-x86-platforms-on-musl.patch \
- file://0001-Fix-compilation-with-GCC-10.x.patch \
- "
+SRCREV = "0e2ce9b9c46c47363436f9ee730f7c71bf455f0f"
+SRC_URI = "git://github.com/lcdproc/lcdproc;branch=master;protocol=https"
S = "${WORKDIR}/git"