aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-30 22:47:41 -0800
committerKhem Raj <raj.khem@gmail.com>2023-02-01 09:11:49 -0800
commit60084508a4f10d7cd136a41cae7882e99bf8b433 (patch)
treea8b456c84a6aa44d4851611f4ab12af815270ffa /meta-oe
parent6e3b7aa52718cdba83c324ee9424f65dbe61748c (diff)
downloadmeta-openembedded-contrib-60084508a4f10d7cd136a41cae7882e99bf8b433.tar.gz
mongodb: Use bfd linker for x86/musl with gcc
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
index 56512a2e2e..253187e33c 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
@@ -74,6 +74,10 @@ WIREDTIGER ?= "off"
WIREDTIGER:x86-64 = "on"
WIREDTIGER:aarch64 = "on"
+# ld.gold: fatal error: build/59f4f0dd/mongo/mongod: Structure needs cleaning
+LDFLAGS:append:x86:libc-musl = " -fuse-ld=bfd"
+LDFLAGS:remove:toolchain-clang = "-fuse-ld=bfd"
+
EXTRA_OESCONS = "PREFIX=${prefix} \
DESTDIR=${D} \
MAXLINELENGTH='2097152' \